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1. Introduction to MT-FormTool

MT-FormTool © is a companion product of FormPac-XP on ID7. It is designed to run on the following
Microsoft platforms: Windows-98, Windows2000 and Windows XP. MT-FormTool uses Microsoft Access
97 for accessing the database. However it is not necessary to install MS Access on the PC if it is not
already installed. The necessary components for creating and accessing MS-Access compatible files are
packaged with the FormTools. The main features of MT-FormTool are listed below:

FormPac-XP Configuration Support (for Stored Formulation application)

e MT-FormTool supports design of Formula, creation and maintenance of Raw Material Table and
Message Tables (for Stored Formulation application) easily on the PC and to download them to ID7.
These tables (database) can be saved on the local PC for subsequent use. FormTool can also read
the existing databases from ID7, which can be saved on a PC. In case of updates to any of the tables,
where only part of the database is modified, the “Sync” option provides convenient and fast
mechanism for synchronizing the PC-based database with FormPac-XP on ID7.

Process Monitoring and Visualization (for all applications of FormPac-XP)

e MT-FormTool can be used to monitor the FormPac-XP dispensing details in real-time. It stores the
dispensing details of all the four applications of FormPac-XP: Formulation, Pharma-Formulation,
Totalizing and Stored-Formulation.

Reports (for all applications of FormPac-XP)

¢ MT-FormTool has capability to provide a wide range of reports, based on the data collected during
FormPac-XP operation. Report Generation Wizard is used to generate graphical and text reports,
based on the dispensed details of all the four applications. It provides various analysis for all the four
FormPac-XP applications. Data can be displayed graphically in several formats: Tables, Histograms,
Pie Charts or Graphs. The reports can be saved (as HTML files or Excel files) and also printed.

Multi-Instance Support

¢ Aninstance of MT-FormTool on a PC can be connected to one ID7 terminal that runs FormPac-XP to
track the operations. Multiple instances of the tool can be invoked to track multiple FormPac-XP
terminals and the data can be logged to a single database file for consolidation of results. The identity
of each ID7 terminal is maintained by assigning a unique Terminal-Id to every instance of FormPac-
XP. Reports can be generated for each terminal or for all terminals from which data was collected.

User Management

e User management determines the level of access to the MT-FormTool. There are 3 different types of
users namely Administrator, Supervisor and Operators. There can be 2 Supervisors and 5 Operators.
The Administrator has all the rights where as the Supervisors and Operators are restricted to some
operations. While Supervisor-level user can change and update Database records on FormPacXP,
Operators are only allowed to log data and produce reports. Whereas user with Administrator privilege
can setup new database tables and terminals.
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Inventory Control

¢ Inventory control tracks stocks in all ID7 terminals associated with the current database file. Stocks of
the ID7 terminals can be managed individually, all together or in groups or even be ignored. And the
option ‘Update Stock’ can be used to update the stock values alone on the 1D7.

Multi-Language Support

e Multi-Lingual support is available for the following languages.

German
English
French
Dutch
ltalian
Spanish

ook wN =

2. Connecting to ID7

Whenever the application starts, it will try to connect to the ID7 terminal.

¢ When the application starts for the first time, Interface Settings dialog box will appear with the
standard settings. Specify the interface parameters and press OK button. Now, the application will try
to connect to ID7. The status bar will show the current status of the application.

If there is no response from ID7 or if the communication settings are wrong, error message will be shown.
In this case, correct interface settings have to be provided.

1) Now, disconnect from ID7 by selecting Disconnect option from the File menu or press Disconnect A
toolbar button.
2) Change the interface settings by selecting Interface Settings from the Options menu or press

Settings toolbar button. The Interface Settings option is enabled only when the application is not
connected with ID7.

3) After changing interface settings, select Connect from the File menu (or press Connect & toolbar
button) to connect again to ID7. The interface settings have to correspond to those available on
FormPacXP.

e If connected properly, the application will read and verify certain data from ID7. If the connected ID7-
FormPac-XP unit is not licensed for using MT-FormTool, a warning message will be displayed. In this
case, the transaction (dispensing) details are not tracked. Please contact Mettler Toledo Service for
upgrade.

e The application will continue to read the Terminal-ld from ID7 (stored in AB004) and makes an entry
in the registry.

If the terminal-id is empty (not assigned) in ID7, the application will provide an option to assign a unique
terminal-id for the connected ID7 terminal. The Terminal-ld dialog box will appear.

1) Enter the Terminal-Id (max of 20 characters) in the edit box.
2) Press OK button.
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The application will write the user-input terminal-id into ID7. If terminal-id is not entered, it will be taken as
‘Unassigned’. The terminal-id is shown in the status bar.

e After verifying the terminal-id, the application will open the corresponding database file. If the tool is
connected with an ID7 terminal for the first time, database file name need to be provided. Enter a new
file name or an existing file name. This file will be associated with the connected ID7 terminal.

¢ If Inventory Control is enabled and Enable Store option is enabled, then a dialog box is shown with
an option to assign the connected terminal with a store. For more details refer the title Inventory
Control.

o The ID7 display panel will show the current scale weight in ID7 with the scale unit and scale-id
details.

e MT-FormTool finds the current application set in ID7 and switches to the corresponding application.
The current application name is shown in the window title.

e If the current application is set to Stored Formulation, then MT-FormTool checks the stored
formulation database Table-lds (TIDs) set in ID7 and in MT-FormTool database file. If the table ids are
not same, it means that the stored formulation database in ID7 and in PC are different. To
synchronize the database and for more information, see Table-IDs section.

For every connection, the session information is maintained in the database file. For more information
about session details, see Session information section.

a. Multi-Instance feature

MT-FormTool can track multiple FormPac-XP by instantiating multiple instances of the tool on the same
PC.

¢ MT-FormTool maintains the settings of each ID7 terminal separately based on the Terminal-Id in the
system registry. For every ID7 terminal, the tool maintains the database file name and communication
parameters separately with a unique terminal-id.

e When MT-FormTool is connected to ID7, it reads the terminal-id from ID7 and gets the corresponding
terminal details from the system registry and loads the corresponding database file.

e If two or more terminals are available, the tool can be connected to an ID7-terminal by selecting the
Terminal-ld option in the Interface Setting dialog box.

e The same database file can be used to monitor more than one ID7 terminal. The dispensing details
from all the ID7 terminals will be stored in a single file if the same database file is used for all the
terminals.

Note:

If an ID7 terminal is connected with MT-FormTool through COMM port (or Ethernet), and if another
instance of MT-FormTool is trying to connect with the same ID7 through Ethernet (or COMM port) from
some other PC, then only the latest connected MT-FormTool instance will receive the state messages
from ID7. The previously connected MT-FormTool instance (through COMM or Ethernet) won’t get any
messages from ID7.

Do not try to connect MT-FormTool with an ID7, which is already connected with another MT-FormTool
instance.
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b. Table IDs (TIDs)

Table IDs (TIDs) are 16 bit signatures maintained to track the changes in Stored Formulation database.
Three TIDs are maintained separately for Raw materials table, Formula table and Message table

Whenever the stored formulation database is changed in MT-FormTool, it updates the TIDs for the
corresponding tables.

When MT-FormTool is connected with 1D7, it verifies the TIDs with ID7. If the TIDs are different, a window
with all TIDs details is shown. The TIDs of changed tables are shown with bold letters. Accept the
message and press OK to continue.

To synchronize the Stored Formulation database:

1. Open DB configuration window by selecting DB Configuration = from the Tools menu.
2. Select Read/Sync/Send option.

When the synching operation is completed, TIDs are updated in ID7.

Every time MT-FormTool is connected with ID7, it logs the session information in the database file. See
Session Information for more details.

3. File Operations

a. Creating a new file
To create a new file, follow the steps below.

1. Select New from the File menu or press New O toolbar button. New file dialog box appears.
2. Enter a name for the new file
3. Press Save button.

A new database file is created and will be opened by the application. In the window title, the newly created
file name is shown.

b. Opening a file

To open an existing database file, follow the steps below.

1. Select Open from the File menu or press Open - toolbar button. Open File dialog box appears.
2. Select the file.
3. Press Open button.

If the specified file is a valid database file, the application will open the file. If the file is not a valid file, then
error message will be shown. The opened file name is shown in the window title.

Page 8 of 60
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c. Saving a file

This option saves the currently opened database file with a new name.
To save the file, follow the steps below.

1. Select Save As from the File menu or press Save As = toolbar button. Save As File dialog box
appears.

2. Enter a name for the new file.

3. Press Save button.

The current database file is saved with the new name. The newly created file serves as the current file.

d. Export Database

Exporting database will copy the Stored Formulation tables to the given database file from the currently
opened file. Save As option copies the entire set of tables including Transaction records, where as
Export will copy only Stored Formulation tables- RM Table, MSG Table and Formula Table. You can
open the newly exported file as any other database file.

The following procedure can be used to export database contents.

1. Open the existing database file where the formula / raw material details have to be changed.

2. Select Export from the File menu.

3. Enter NEW file name and press Save button. The DB Configuration contents will be exported to this
file.

The Export option will be mainly used when the stored formulation database is changed. Please refer the
topic Impact on modifying database for more details.

e. Import Database

Import database option will copy the Stored Formulation tables from the given database file to the
currently opened file. For importing database, the corresponding tables in the current file should be empty.
That is, a new set of Stored Formulation Tables cannot be imported into a Database file that has these
tables established. The import operation is allowed only once — when a New Database File is opened
(after File->New operation).

The following procedure can be used to create a new file with exported database contents.

1. Create a New Database File.

2. Select Import from the File menu and Import the saved DB Configurations. That is, enter the file
name whose DB configurations have to be copied to the currently opened file.

3. The Stored Formulation tables will be imported from the existing database file to the new file.

4. Now change the database contents in the new file and download (or sync) this file to ID7 and start
using this file.

The Import option will be mainly used when the stored formulation database is changed. Please refer the
topic Impact on modifying database for more details.
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4. Monitoring Applications

MT-FormTool will monitor the dispensing details of all applications in FormPac-XP.
The following applications are monitored by the MT-MT-FormTool.

Formulation

Pharma Formulation
Totalizing

Stored Formulation

a. Formulation

In Formulation, the containers and their individual component weights are monitored by the MT-FormTool.

Each container is tracked by a serial number. For every container, the tool shows the recipe (formula)
name, start date, start time and end time.

The component details for the selected container are shown in the table view. The table view shows the
component number (1-15), component name, dispensed weight, dispensed time and the scale id in which
it is dispensed.

For components dispensed using scale, the weight in the table view is shown in blue color. For manually
dispensed components, the dispensed weight is shown in black color.

In Formulation application, the main window will look like the figure below.

T-FormTool: admin - Formulation - [Samplel.mdb] P ] 5|
File Users Mew Toole Application Options Language Help

Nl es s UE &P

S.oMo|3 -l Recipe; | FirstRecipe
Diate: | 0940172002 Starttime: | 17:43:44  Endtime: | 17.55:04

| C Mo ‘ Matme ‘ Wigight ‘ Dispensed Time | Scale ld ‘
I [
2 Flour 0.064 kgy 17:43:52 3

3 Sugar 0.05 ky 17:44:08

4 Soda 0.024 ky 17:44:44 1

5 Color 0.044 kg 17:47:16 1

-] Wister 0064 kg 17:47:49 1

i Ghes 0022 kg L5218 i

i) Iilk 0.036 kg 1T:5319 il

El Salt 0.026 ky 17:55:03 1
Tatal: Tare:

0.382 kg 0.108 kg
Ready |Connected Terminal 1d: 1D7-Terminall
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b. Pharma Formulation

The tool tracks the component name, dispensed weight, tare weight, dispensed date and time and scale
id. All the components are shown one by one in the table view.

For components dispensed using scale, the weight in the table view is shown in blue color. For manually
dispensed components, the dispensed weight is shown in black color.

In Pharma Formulation application, the main window will look like the following figure.

MT-FormTool: admin - Pharma Formulation - [Samplel.mdb] = Ellll

File Users “ew Tools Application Options Language Help

el es | 0a|e ®

S Mo Componert Matne | Component Weight | Tare Wei... | Dizpensed Date Titne: Scale ld

i Compl 0066 ky 0.0534 kg | 10/01/2002 105232 1

2 Comp2 0.052 ky 0.000 kg | 1040172002 10:52:47 1

3 Comp3 0078 ky 018 kg | 100012002 10:54:26 2

4 Compd 0.055 ky 10001 F2002 110914

] Comps 0.066 kg 0.000 kg | 1000172002 114214 1

=] Compl 0066 ko 0000 kg | 10001 2002 114233 3

i Comp? 0.080 ky 0066 kg | 10001 2002 11:42.56 1

g Compd 0134 ky 0.000 kg | 10/01/2002 11:44:36 1

9 Compd 0.055 ky 10001 f2002 11:45.07

10 Compl 0 0.07 ky 10001 2002 11.4517

11 Comgrl 1 0055 kg 0.094 kg | 10001 £2002 114502 1
Ready |Connected Terminal 1d: ID7-Terminall

c. Totalizing

The tool tracks the component name, dispensed weight, dispensed date and time and scale id.

For components dispensed using scale, the weight in the table view is shown in blue color. For manually
dispensed components, the dispensed weight is shown in black color.

In totalizing application, the main window will look like the following figure.
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T-FormTool: admin - Pharma Formulation - [Samplel.md

ib] =

Fle Users Wew Tools Application Options Language Help

EHeEs i |Ule | ¢ P

S Mo Component Name | Component YWeight | Tare wWisi.. | Dispensed Date Time i Scale ld
1 Compd 00685 kg 0.054 ky | 10001 2002 105232 1
2 Comp2 0.052 kg 0.000 ky | 1000 2002 10:52:47 1
g Comp3 0.078 kg 0418 ky | 1000142002 10:54:26 2
4 Compd 0058 kg 100012002 11:09:14

3 Caomps 0066 kg 0.000 kg | 1000152002 11:4214 1
B Caompi 0066 kg 0.000 ky | 1000152002 11:42:33 3
% Camp? 0.080 kg 0.066 ky | 10172002 11:42:56 1
8 CompE 0134 kg 0.000 ky | 10152002 11:44.36 1
9 Compd 0.055 kg 400012002 11:45:07

10 Comp10 0.07 kg 10002002 11:4517

11 Compd 1 0.058 kg 0.094 ky | 100 42002 11:48:02 1

Ready Connected Terminal Id: 1ID7-Terminall

d. Stored Formulation

Whenever a formula is selected and dispensed in ID7, the MT-FormTool application will read and store
the details of the formula selected and its compounds. When multi-charge option is enabled (Kitting) in
ID7, the application will log every split-dispensed detail.

Formula Details

When a formula is selected for dispensing in ID7, MT-FormTool will read the details of the selected
Formula and all of its compounds. In the main window, the formula details are shown below the ID7-Panel
(Weight Display). The compound details are shown in a table.

When a formula is selected, the tool will read and display formula name, formula id, lot number,
dispensing start date, start time and end time. And formula target weight, actual weight and tare weight
are also shown below the table view.

Compound Details

When a compound is selected for dispensing, the corresponding compound in the table view is highlighted
by means of blinking the item with a green color. The compound is blinked until the compound is either
dispensed or cancelled.

When the compound is selected, the table view shows the compound name, target weight, tolerance
weight and start time of dispensing. Once the compound is dispensed its dispensed weight, dispensed
tolerance (Delta) and scale-id are updated in the table view. During dispensing the status bar displays the
current state of the compound (e.g. selected, dispensed or cancelled).

Multi-charge (Kitting)
If the multi-charge option is enabled, the individual split dispensing details (Dispensed Wt, Charge No)
will be shown in the table view for every compound.

The compounds details can be viewed in two ways namely Expand and Shrink mode. Any one of these
options can be selected by right clicking the mouse on the table view and selecting the appropriate option
in the pop-up menu.
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The Shrink menu option will show only the compound name, target, tolerance, and dispensed weights.
The Expand menu option will show all the split-weights, all charge numbers, scale id and start time (and
hides columns that has no data).

Scale Id
If the compound is dispensed using scale (not manually), the corresponding scale id is shown in the last
column of the table view. If the compound is dispensed manually, the scale-id is not shown.

Batch Mode

If a formula is dispensed in BATCH mode, the tool displays individual batch weights (for each compound)
along with compound name, target and tolerance weights. The columns with labels Disp wt_1, Disp Wt_2,
... Disp Wt_N shows the batch weights, where N is total number of batches.

The charge number for each compound is shown in the last column of the table view. The formula target
weight, total number of batches and the current batch id are displayed below the table view. While
dispensing, the current batch id is updated with the selected batch. The status bar will display the current
iteration number and compound number when the compound is selected for dispensing. The current batch
id is shown only during dispensing.

Parking

If the formula is parked during dispensing, the application stops logging and the formula status is updated
as Parked. The formula status is shown just below the ID7 display panel. When the parked formula is
loaded, the application will load the corresponding formula that is already stored in the database file.

Formula Status
The formula status describes the dispensing status of the formula. The following are the different formula
status with description.

‘Dispensed’ - The formula was dispensed

‘Parked’ - The formula was parked

‘Cancelled’ - The formula was cancelled
‘Dispensing’ - The formula is being dispensed
‘Interrupted’ - Dispensing was interrupted by the user

(If the user disconnects or closes the MT-FormTool application while dispensing a formula, the status is
updated as ‘Interrupted’)

Color-coding
For manually dispensed compounds, the dispensed weight is shown in black color. Otherwise the

dispensed weight is shown in blue color.

If the delta value is negative, it is shown in red color. It is shown in light gray color if it is a positive value.
If the delta is exactly zero, then it is shown in green color.

Note:
For BATCH dispensing, there is no color-coding. In batch mode, all the values are shown in blue color.

Terminal-ld
The terminal-id displayed in edit box shows from which ID7 terminal the current formula was dispensed.

The terminal-id in the status bar shows the terminal-id of the connected ID7 terminal. The terminal-id
shown in the edit box (above the table view) shows the terminal-id in which the currently loaded formula is
dispensed.

Screen samples
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MT-FormTool: admin - Stored Formulation - [Samplel.mdb] = |EI|1|
File Users Wiew Tools Application ©Options Language Help
Ded a3 U8 &|@
=
£y
D7 Display
|
| DISPENSED Terminal T | ID7-Terminall
5. Mo |2 - Formula IC: | F_ID_001 Formula: |Elread
Date: [ 10172002 Starttime: 160013 Endtime: [1610:18 Lot Number| LOTHUMBER1

SHo | RM | Targetvt | Toiva| Dispwt|  Detta|la| nem —

1 Flour 0515ka | 0077 kg D584 kg | 0077 ko

2 Wizter 0342ky 0063 ky 0294 kg -0.048 kg 420 Fie Chart

3 Sugar 0137 ky | 0024kg 0134 kg | 0003 ky s

4 Cheese 0.051 ky | 0.007 ky 0.004 ki

s Essence 0.007 kg 0.005 kg na1e S

C

7 Color 0017kg 0.007 kg | 0.022 kg 0,005 kg -

8 Yeast 0017 ky | 0007 kg 0016 ky | -0.001 kg S Chart

3 Satt 0051 kg | 0.0M0kg 0042 kg | -0.009 kg

100 Dz f1m, 0017 key OO0 e | DLOF b 0002 L, 0108  ——

il

Target: Actual Tare: i D fm] I.I:LD.E.E

| 1.230kg 1.257 kg |0.362 kg

|Connected Terminal Id: ID7-Terminall

Stored formulation — Vertical/Horizontal Mode

§ 'MT-FormTool: admin - Stored Formulation - [Samplel.mdb]
File

Users Wiew Tools Application Options Language Help

=0l

-
EH s 3 UE &
| DISPENSING Terminal ID: ID7-Terminall
5. MNo: |3 vl Formula |D: | F_ID_001 Formuls: |Elread
Date: | 1040172002 Start time: | 171503 End time: | Lot Murnber:| LOTHUMBER?
SNo | RM [ Tergetwa] Tolwt | Dispwt1| Dispiz | Charge Mo | [~
1 Flour 0333 kg 0050ky | 0304ky | 0358ky 1
) Water 0222 kg 0044ky | D224k | 0218k c2
3 Sugar 0,089 kg 00M6ky | 0085ky | 0095 kg ci
4 Cheese 0033 kg D004ky | 0D03Bky | 0036 ky c4
s Eszsence 0.011 kg 0.004 kg 0.010 ky 0.014 ky g5
3 Egg 0,044 kg 0007 ky | 0042kg | 0044 kg ce | [
# Color 0.011 kg 0.004 ky (0.010 kg 0.092 ky G Curtent DI
= 011 oI 004 o 8I-E|—% srrent Jspensing
a ok A e A AT Lo Compound
Batch 2
Target: Total Batches: Current Batch Id: Balch:d
0.800 kg 2 | Batch-id-1

|Connected Terminal Id: ID7-Terminall

Stored formulation — Batch Mode

Charts / Graphs

Compound weights can be visualised graphically during monitoring. Three types of graphs are provided,
namely Pie, Histogram and Progress Bar. The required chart can be selected by right-cliking the mouse
on the chart and selecting the graph option from the pop-up menu.

FormToolXP_Operating Instructions_engl.doc
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Different colours are used in a chart to identify dispensed compounds. Compounds that are not dispensed
are shown in WHITE (default) colour.

Pie chart and Histogram supports upto 20 compounds. If more than 20 compounds exist in a formula, then
they are represented via Progress Bar.

e. Switching between applications

There are four applications in FormPac-XP. Once the tool is connected with ID7, the tool will read the
current application in ID7 and switches to that application.

Once connected, the tool cannot switch to other applications. To view the contents of other applications,
first disconnect from ID7 and then choose any one of the applications from the Application menu. The
tool will switch to the selected application and the entire window contents will show the details of the
selected application (The current application is shown with a tick symbol in the Application menu). The
current application is also shown in the window title.

Note:
The option DB Configuration in the Tools menu is enabled only when the current application is set to
Stored Formulation.

5. Stored Formulation Database

To view or design formula database, select DB Configuration from the Tools menu or select e toolbar
button. DB Configuration window will appear. The RM, Formula and Message toolbar items are used to
edit Raw Materials, Formulae and Message databases correspondingly. By default Raw Materials table is
shown.

Note:
The DB Configuration option in the Tools menu is enabled only when the current application is set to
Stored Formulation.

a. Designing Raw Materials

Click the toolbar item named RM in DB Configuration window. The RM table is shown with 500 raw
materials.

To edit a RM, follow the steps below.

1) Select the raw material (row in the table) to edit.

2) Press Edit button (or Right click the mouse on index (first) column and select Edit from the pop-up
menu).

3) Enter the RMid (unique), Description, Message ID, Stock, Warning level. Consumed, Stock Date,
Stock Time and Used Count are not editable.

4) Press Save button (or right-click on the index column and select Save from the pop-up menu). Or
press Cancel button (or select Cancel from the pop-up menu) to cancel the updates.

Note:
If the raw material is already created, raw material id cannot be changed. To change the raw material id,
delete the raw material and create it again.
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RM table constraints:

1) RM Id can be of up to a maximum of 20 characters. It must be unique.
2) RM Name can be of up to a maximum of 30 characters.

To delete a raw material, follow the steps below.

1) Select the raw material to delete.

2) Press Delete button (or right click the mouse on index (first) column and select Delete from the pop-
up menu).

3) Press OK button to delete the raw material or Cancel button to cancel the deletion.

Note:
Raw material can be deleted only if its used count is 0. For empty records, the used count will be empty.

Please refer Impact on modifying database topic when changing database.

The RM table will look like the following figure.

T-FormTool - DB Configuration J == ]
o O F=Cic, @ é% B Q M
RM Formula Message Send Read Sync DB Info Stack Clase
R Materizls
Description Stock
ID_001 Pre tare

2| Raw__ Material_ID_002 water <ENTER:= 2.000 kg

3| Raw__ Material_ID_003 Salt 0.910 kg

4] Rawe Material_ID_004 weast Load container 0.000 kg

5| Raw__ Material_ID_005 Grapes 1.438 kg

6| Raw__ Material_ID_006 Cherry 0.000 kg

7| Raw__Material_ID_007  Milk 0.000 ky

8| Raw__ Material_ID_008 Sugar 0.000 kg

9| Raw__ Material_ID_002 Apple Select scale 1 0.000 kg

10] Raw__ Material_ID_010 Sugar Load container 1.000 kg

11] Raw__Material_ID_011 Tomato 0.000 kg

12| Raw__ Material_ID_012 Banana 0.000 kg

13| Raw__ Material_ID_013 Pine Apple  Load container 1.908 kg
14] Raw_ Material_ID_014 Qrange 4.400 kg =
[<] | ﬁ

# et | == Delete
Raw Material 1 selected

b. Designing Formulae

Click the toolbar item named Formula in the DB Configuration window. The formula tables are shown.
There are two tables in the formula. The upper table called Formula Table shows the formula details and
the lower table called Compounds Table shows formula compounds details for the selected formula.
There are 150 formulae in the formula table.

To edit a formula in formula table, follow the steps below.

1. Select the formula to be edited in the formula table.
Press Edit button (or right click the mouse on index (first) column and select Edit from the pop-up
menu).

3. Enter the Formula ID, Formula name, three Pre-Messages and two Post-Messages.
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4. Press Save button (or right-click on the index column and select Save from the pop-up menu). Or
press Cancel button (or select Cancel from the pop-up menu) to cancel the updates.

Note:
If the formula is already created, formula id cannot be changed. To change the formula id, delete the
corresponding formula and create again.

Formula table constraints:

e Formula Id can be up to maximum of 10 characters.
e Formula Id must be unique.
e Formula Name can be up to maximum of 30 characters.

To delete a formula in formula table, follow the steps below.

1. Select the formula to be deleted in the formula table.

2. Press Delete button found below the formula table (or right click the mouse on index (first) column in
formula table and select Delete from the pop-up menu). A warning message will be displayed

3. Press OK button to delete the formula or Cancel button to cancel the deletion.

Note:
Deleting a formula deletes the formula and all of its compounds.

To add a compound, follow the steps below.

1. Select the formula to be edited in formula table. The corresponding compounds will be shown in the
compounds table.

2. Select an item in the compound (lower) table.

3. Press Edit button found below the compounds table (or right click the mouse on index (first) column
and select Edit from the pop-up menu).

4. Select the Raw Material ID from the (RM ID column) list. The corresponding raw material name will be
shown in the next (RM Name) column.

5. Enter target weight, tolerance weight, pre-message and post-message.

6. Press Save button found below compounds table (or right click the mouse on index (first) column in
compound table and select Save from the pop-up). Or press Cancel button (or select Cancel from the
pop-up menu) to cancel the updates.

To add more compounds follow the steps above. The same compound can be added more than once in a
formula.

Constraints:

¢ A maximum of 100 compounds can be added for a formula.
e Tolerance weight must be less than or equal to half of the target weight. Otherwise it can have a value
up to 50%.

To edit/change a compound, follow the steps below.

1. Select the formula to be edited in formula table. The corresponding compounds will be shown in the
compounds table.

2. Select an item in the compound (lower) table.

3. Press Edit button found below compounds table (or right click the mouse on index (first) column and
select Edit from the pop-up menu).

4. Change the compound details.

5. After changing the compound values press Save button (or right click the mouse on index (first)
column and select Save from the pop-up). Or press Cancel button (or select Cancel from the pop-up
menu) to cancel the updates.
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To delete a compound, follow the steps below.

1. Select the formula to be edited in formula table. The corresponding compounds will be shown in the
compounds table.

2. Select an item in the compound (lower) table.

3. Press Delete button (or right click the mouse on index (first) column and select Delete from the pop-
up menu). A warning message will be displayed.

4. Press OK button to delete the compound or Cancel button to cancel the deletion.

The formula table will ook like the following figure.

¢ MT-FormTool - DB Configuration o ] [R5
© O e, W ok | I%Ig = Q i
R | Formula ~ Message Send Read Sync DE Info Stock. Close
Formula
Index | Formula ID | Formula Name | Fre Msg 1D 1 | Pre Msg 1D 2 | Breis
1] FID1 Pepsi Load container Zero scale
2| FID2 Mixer Lot number
‘ OR A0S Change container _-
4 Select scale 1
¥
7 al FInnne Pensi LInlnad r“:-uIFl‘ IIF‘
Compounds: 4 # e | == Delete |
Incex | Bk 1D Rhi Name | Weight | Tolerance | Pre Msg 1D
ateri: m 20 g | Enter compound
2| Raw__ Material |D_002 water 200 g 20 g
3| Raw__ Material I[D_017 Lemon 1780 40 g Unload scale
41 Raw _ Material_ID_005 Grapes 192 g 10 %
]
\ | [
& Edi | == Dekete

Compound 1 selecked

Please refer Impact on modifying database topic when changing database.

c. Designing Messages

Click the toolbar item named Message in DB Configuration window. There are 200 items in the message
table. First 30 messages are read-only messages and they cannot be modified.

To edit a message, follow the steps below.

1) Select an item (row in the table) to edit.

2) Press Edit button (or right click the mouse on index (first) column and select Edit from the pop-up
menu).

3) Enter the Message text.

4) Press Save button (or right-click on the index column and select Save) to save the changes. Or press
Cancel button (or select Cancel from the pop-up menu) to cancel the updates.
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Note:

e Messages 1 to 30 are fixed messages and cannot be edited.
o Message text can be up to a maximum of 24 characters.

To delete a message, follow the steps below.
e Select an item (row in the table) to edit.
o Press Delete button (or right click the mouse on index (first) column and select Delete from the
pop-up menu). A warning message will be displayed.
o Press OK button to delete the message or press Cancel button to cancel the deletion.

The message table will look like the following figure.

-FormTool - DB Configuration i = |E! 5'

o, 8 Retec @ L2 Eam @ M
RM Formula | Message Send Read Sync DB Info Stock Close
Messages
Index | Description A
1| Load container L

2| Load container, <TARE=

3| Change container

4| Unload scale

§| Change scale, <ENTER»

6| Pre tare

7| Zero scale

8| Lot number

3| Charge number

10| Confirm raw material D

1] <ENTER>

12| Enter farmula

13| Enter campound

14| Enter customer

18] Order number fid
& cat | = De\etel

Message 37 selected

Please refer Impact on modifying database topic when changing database.

d. Sending Database to ID7

The entire database (includes Raw materials, formulae and messages) can be downloaded to ID7 by
clicking the Send toolbar item. Before downloading, the application will delete all the raw materials,
formulae and messages in ID7 and then it will start writing messages, raw materials and formulae to ID7.
A warning message will be shown before updating the data in ID7.

e. Reading Database form ID7

1. To read the database from ID7, press the Read toolbar item in the DB Configuration window. A dialog
box with the reading options will be shown.

To read all tables (i.e., Raw materials, Formulae and Messages), select ReadAll option.

To read individual tables, choose Read option and select any of the tables.

Press OK button to start reading. Now the selected tables in the local database file will be cleared to
hold the new data.

roON
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5. A warning message is shown regarding this action. Press Yes button to clear the selected tables and
start reading the selected tables from ID7.

f.Synchronizing Database with ID7

The Sync option is used to synchronize your database with the ID7. This will update the database in ID7
with the database in MT-FormTool. Once the entire database is read from ID7, database need not be
downloaded every time when small changes were made.

If the entire database is read from ID7, and if any changes were made (adding, editing or deleting some
records), only the changed records will be updated in ID7 by Synchronization. This can be invoked by
pressing Sync toolbar item. Sync saves the time.

When this option is used, the application assumes that the user has already read the entire database
recently.

If the database in ID7 is changed by some other means (i.e., without using MT-FormTool), then the sync
option may not work properly. In these cases, the entire database should be read again to use sync.

g. Session Information

Every time MT-FormTool is connected with ID7, current session information is stored in the database file.
To view session information,

1) Open DB Configuration window by selecting DB Configuration ({pmc DBConfig.bmp}) from the
Tools menu.
2) Select DB info toolbar button.

Session information window appears. In this window, current database file name, file size, three TIDs are
shown. All the session information taken for every connection is displayed in the list view.

The list view contains the following details.

Serial no.

Terminal ID.

User Name

Date and Time at which the connection established.

Record No (no of formulae dispensed when connection is established).
Message TID, RM TID and Formula TID at the time of connection.
Session Status showing whether the database is synchronized or not.

~NO O WN —
—_—— S = ——

Clearing Logged Info:

The logged session information can be cleared by selecting Clear Logged Info from the Tools menu.
This option will also delete the user logging information file lodfile.txt stored in the MT-FormTool
installation directory.
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6. Report Generation

a. Reports - Introduction

Report Wizard provides a range of reports based on the data collected by MT-FormTool. The Wizard is
used to generate graphical and text reports, based on the dispensed details for all the four applications of
FormPac-XP.

The Wizard provides different types of analysis as follows:
Stored Formulation:

e Trend analysis
e Error analysis

e Consumption analysis
e Production analysis

Formulation:
Recipe and Component analysis

Pharma-Formulation & Totalizing:
Components analysis

The data can be displayed graphically in several modes namely Tables, Histograms, Pie Charts or Plots.

The Advanced Reports section can be used to generate customized reports. Using Advanced Reports,
user can design a query based on database fields to produce required reports for all the FormPac-XP
applications. For more details, see Advanced Reports section.

The Reports Application provides the following features:

Print the generated report

Customize styles (namely Fonts, Colors and Tags)

Customize Header and Footer (allows to configure 1 line for header and 2 lines for footer)
Save the generated report for future reference (saves as HTML file or Excel file).

b. Starting Wizard

e To invoke the report generation wizard, choose Reports from the Tools menu (or press Reports

G toolbar button) in the MT-FormTool main window.

e The report generation tool appears with the option to choose the database file. By default, the current
file that is opened by the MT-FormTool will be shown. Select this file or browse for an existing one and
press OK button to continue.

e The Report Generation Wizard appears. The first page of the wizard is shown in the following figure.

¢ In the first page of the wizard, select the type of application. Choose any one of the following four
applications in the wizard.

1) Stored Formulation
2) Formulation

3) Pharma Formulation
4) Totalizing
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e Select the ID7 Terminal-lds to which the reports have to be produced. See Visualizing Multiple ID7
Terminal Reports for more details.

e The reports can be generated based on the user name. Select the user names. See Visualizing
Reports for Multiple Users for more details.

Note:

N

To invoke wizard manually, select Wizard from the Tools menu or press wizard % toolbar button.

Back option

Once the report is generated and if any minor change has to be done in the current report, it can be easily
done by using Back toolbar button. This option enables the user to go back to the previous interface from
which the active report was generated. To make any change in the current report, follow the steps below.

1. Press the Back toolbar button in the reports window. The previous wizard/advanced reports
window will appear.
2. Make the necessary changes and generate report again.

Pressing Back toolbar button will clear the current report and go back to the previous Wizard screen or
Advanced reports window which ever is appropriate. This can also be done by choosing the menu option
Back from the View menu.

Wizard screen is shown below.

FormTool Report Wizard - 1/2 ) x|

Bazed On

alysi
Stored formulation
= Trend Analpsiz

o Terminal I
- 3 |Umt2
i Analpsis

 Production Analysis User Name

(ﬁ‘ Fomula " Baw material |

= Foimulation i~ Shiow by
{+ Teminal ID
 User Mame
” Bath

" Phama formulation

" Totalizing

-Chait / Report
£ Histogram
* Plat Graph
= Ple Chart
1 Tewt Report

“ariation of Errar (in %] in a formula far
wanous dispensations.

Advanced Reports |

< Back I Hest » i Cancel

c. Graph Options

The following graph options are available in the wizard.

Show batch results separately:
If this option is selected batch mode dispensing are shown separately.
This option is available only for “Trend Analysis” and “Error Analysis”.

Show Grid:

If this option is enabled in Histogram or Plot graph, the report is shown in grid fashion.

In text report if this option is enabled, the report is shown with rows and columns spanning the entire
report.
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d. Advanced Reports

Apart from the standard reports produced by the MT-FormTool's Reports Wizard, user can also generate
customized reports using "Advanced Reports" feature.

Using Advanced Reports, user can design queries based on database fields to produce required reports
for all the FormPac-XP applications.

In Stored Formulation, in addition to the dispensed details, the original Formula/Raw material/Message
database details can also be analyzed. For example, listing all the formulae that use a specific Raw
Material.

The major features of Advanced Reports are highlighted below:

e Constraints (conditions) can be used in queries to retrieve filtered data.

¢ During query designing, all the fields and their constraints (conditions) will be available in individual
columns that can be selected by the user as required.

e The designed query can be saved and retrieved for future use. Any number of such queries can be
designed and saved.

Back option

Once the report is generated and if any minor change has to be done in the current report, it can be easily
done by using Back toolbar button. This option enables the user to go back to the previous interface from
which the active report was generated. To make any change in the current report, follow the steps below.

1. Press the Back toolbar button in the reports window. The previous wizard/advanced reports
window will appear.
2. Make the necessary changes and generate report again.

Pressing Back toolbar button will clear the current report and go back to the previous Wizard screen or
Advanced reports window which ever is appropriate. This can also be done by choosing the menu option
Back from the View menu.

e. Opening a Database file for Reports

Reports are generated for a database file. Before generating a report, a valid database file must be
opened for which the reports shall be generated. By default, the wizard takes the currently running
database to generate reports.

Otherwise any other database can be made open by selecting Open option from File menu or by pressing

=

Open toolbar button.

f.Visualizing Multiple ID7 Terminal Reports

Multiple Terminal-IDs:

MT-FormTool monitors multiple ID7 terminals and the data from all the ID7 terminals can be logged on to
a single database file. Reports can be generated for more than one Id7 terminals.

Select the required terminals from Terminal-ID option list in the wizard’s first page.
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If multiple Terminal-IDs are selected, reports can be used to produce consolidated results or the same
report can be used for displaying each 1d7 terminal results in a distinct fashion. In such a case, a
maximum of three ID7 terminals are shown in the produced report.

The option Terminal-ID in Show by section is allowed only in Error, Consumption and Production
analysis of Stored Formulation application. This option is allowed for a maximum of 3 Terminal-IDs.

If this option (Terminal-ID) is selected, the resultant report will be shown as follows:

Histogram Representation : Shown as a 3D chart.
Plot Representation : Individual plots are used to represent each Terminal-Id.

Otherwise, the report is shown as follows:

Histogram Representation : Shown as a 2D chart.
Plot Representation : Single line graph is shown.
Note:

Irrespective of multiple Terminal-IDs option, if the number of samples exceeds 15, then 3D charts cannot
be accommodated. In this case, a 2D chart is displayed.

Wizard screen is shown below.

FormTool Report Wizard - 1/2 . 1'
—&nalysic————————— ~BasedOn
Stared forrulation ’75 Formula " Baw material ‘

" Trend Analysis
« s

: Terminal [T
& Lnit2
" Consumption Analysis

User Mame

" Production Analysis

" Formulation ~Show by
" Pharma formulation & Teminal ID
o ke " User Name
= Baoth
Ehartl..-" Report ‘Wariation of Eror (in %] in a farmula for
= Histogram vanous dispensations.
% Plot Graph
€ Fie Chart e
" Text Report : ‘:1
) VALY
S Sanp ler
Advanced Reports | ::1

<Back I Mest » I Cancel

g. Visualizing Reports for Multiple Users

Multiple User Names:

MT-FormTool tracks the user name during dispensing. Reports can be generated for more than one user
name. Required user names can be selected from the User name option list in the wizard’s first page.

If multiple user names are selected, reports can be used to produce consolidated results or the same
report can be used for displaying results for each user. In such a case, a maximum of three user names
are shown in the produced report.
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The option User name in Show by section is allowed only in Error, Consumption and Production analysis
of Stored Formulation application. This option is allowed for a maximum of 3 user names.

If this option is selected, the resultant report will be shown as follows:

Histogram Representation : Shown as a 3D chart.
Plot Representation : Individual plots are used to represent each Terminal-Id.

Otherwise, they are shown as follows:

Histogram Representation : Shown as a 2D chart.
Plot Representation : Single line graph is shown.
Note:

Irrespective of multiple user name option, if the number of samples exceeds 15, then 3D charts cannot be
accommodated. In this case, a 2D chart is displayed.

Wizard screen is shown below.

FormTool Report Wizard - 1/2 i il
—dnalys -Baged On
Stored formulation ’rﬁ' Fomula " Baw material |
 Trend &nalysis
1+ Enor Analysis L=l p
el Urit2
" Consumption Analysis
User Name

" Production Analysis

" Fomulation Shaow by =
£~ Pharma formulation ' Teminal ID
¢ el " Usger Mame
" Bath
e Chart.." Report WYariation of Errar (in %] in & farmula for
€ Histogram various dispensations.
% Plot Graph
= Fie Chart 1
" Text Report [ ‘:1\ FRAvARI
Lo £
Lt
Advanced Reports | i

< Back l Nexst > I Cancel

h. Stored Formulation Reports

In Stored Formulation, reports can be used to view “Dispensing details of Formula / Raw Materials”, “Error
in dispensing of Formula / Raw Materials”, “Usage of Raw Materials” and “Production of formulae”.

The report types are categorized as follows:

Trend Analysis

Error Analysis
Consumption Analysis
Production Analysis

A OWON -
= = ——

Select any item to view details.
Trend analysis
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Trend Analysis is used to analyze the target and dispensed weights of a formula or a compound (raw
material) in a formula. To generate Trend Analysis report, follow the sequence of steps given below.

¢ Inthe FormTool Report Wizard screen, select the option Trend Analysis.

¢ In Based On section, select the option Formula or Raw Material.

e Select the required terminal-ids and user names from the Terminal-ID list and User name list
respectively.

e Intrend analysis, either Histogram/Text report can be produced. Select the desired chart in the
Chart/Report section.

e Press the Next button. Second page of the wizard appears.

e [f the analysis is selected based on formula, then a list of formula Ids is shown in the Formula ID
drop-down list. Select a formula id from the list. The corresponding formula name is shown nearby.

e [f the analysis is based on raw material, then a list of raw materials is shown in the Raw Material Id
drop-down list. Select a raw material id from the list. The list of formulae that use this raw material will
be listed below in the Formula Id drop-down list. Select any one formula id from the list. (A formula
can use a raw material more than once. In this case, a list of duplicated compounds will be displayed,
which can be selected).

e Select the further options Date range and Graph Options.

e After selecting the report options, press Finish button to generate the report.

The generated trend analysis report is shown.

Error analysis

The dispensed value of a raw material or formula may deviate from their target weights. In Error
Analysis, the percentage of error during dispensing of each raw material or a complete formula can be
analyzed. The graph shows the error values of eachdispense operation. The total deviation of the
samples is shown at the bottom of the graph.

To generate Error Analysis reports, follow the procedure given below.

¢ Inthe FormTool Report Wizard screen, select the option Error Analysis.

¢ In the Based On section, select the option Formula or Raw Material.

e Select the required terminal-ids and user names from the Terminal-ID list and User name list
respectively.

e In Error Analysis, either Plot/Text report can be produced. Select the desired chart in the
Chart/Report section.

e Press the Next button. Second page of the wizard appears.

e Ifthe analysis is selected based on formula, then a list of formula Ids is shown in the Formula ID
drop-down list. Select a formula id from the list. The corresponding formula name is shown nearby.

e Ifthe analysis is based on raw material, then a list of raw materials is shown in the Raw Material Id
drop-down list. Select a raw material id from the list. The list of formulae that use this raw material will
be listed below in the Formula Id drop-down list. Select any one formula id from the list. (A formula
can use a raw material more than once. In this case, a list of duplicated compounds will be displayed,
which can be selected).

e Select the further options Date range and Graph Options.

e After selecting the report options, press the Finish button to generate the report.

The generated error analysis report is shown.

Consumption analysis

In consumption analysis, usage of raw materials is analyzed. This analysis focuses on stock
management.
The following four reports can be generated in consumption analysis.
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Total consumption
Date-wise report
Highly consumed
Least consumed

B WN -
= ——

To generate the report, the procedure listed below can be followed.

¢ Inthe FormTool Report Wizard screen, select the option Consumption Analysis.

e Select the required terminal-ids and user names from the Terminal-ID list and User name list
respectively.

e In Consumption Analysis, Histogram, Pie Chart or Text report can be produced. Select the desired
chart in the Chart/Report section.

e Press the Next button. Second page of the wizard appears.

¢ Now, select the required report type listed below.

Total usage of raw materials: (Total consumption)

This report shows the usage of selected raw materials. To view this report, select the required raw
materials from the list provided in Choose Raw Materials section.

Date-wise report for a raw material: (Date-wise report)

This report shows the usage of a raw material in the given date range. To view this report, select the
required raw material from the list provided in Choose Raw Materials section.

Most used raw materials: (Highly consumed)

This report analyses highly used raw materials. The section Top can be used to specify the top N highly
used raw materials.

Least used raw materials: (Least consumed)

This report analyses least used raw materials. The section Top can be used to specify the top N least
used raw materials.

e Select the further options Date range and Graph Options.
e After selecting the report options, press the Finish button to generate the report.
The generated consumption analysis report is shown.

Production analysis

In production analysis, the production of formulae is analyzed. This analysis focuses on production
management.

The following five reports can be generated in production analysis.

Total production of formulae

Dispensed, Cancelled and Parked count of each formula
Date-wise report for a formula

Highly consumed

Least consumed

AR WN -
== ——

To generate the report, follow the procedure listed below.

¢ Inthe FormTool Report Wizard screen, select the option Production Analysis.
e Select the required terminal-ids and user names from the Terminal-ID list and User name list
respectively.
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¢ In Production Analysis, Histogram, Pie Chart or Text report can be produced. Select the desired
chart in the Chart/Report section.

e Press the Next button. Second page of the wizard appears.

¢ Now, select the required report type listed below.

Total production of formulae:

This report shows the production of selected formulae. To view this report, required formulae can be
selected from the list provided in Choose formulae section.

Dispensed, Cancelled and Parked count of each formula:

This report shows the dispensed, cancelled and parked count of the selected formula. To view this report,
select the required formula from the list provided in Choose formula section.

Date-wise report for a formula:

This report shows the production of a formula in the given date range. To view this report, select the
required formula from the list provided in Choose formula section.

Highest volume produced: (Highly consumed)

This report analyses highly produced formulae. The section Top can be used to specify the top N highly
produced formulae.

Least volume produced: (L east consumed)

This report analyses least used produced formulae. The section Top can be used to specify the top N
least produced formulae.

e Select the further options Date range and Graph Options.
e After selecting the report options, press the Finish button to generate the report.
The generated production analysis report is shown.

i. Formulation Reports

In Formulation, reports can be used to view weight details of Recipe / Components.
To generate the report, follow the procedure listed below.

¢ Inthe FormTool Report Wizard screen, select the option Formulation.

¢ In Based On section, select the option Recipe or Components.

¢ In Formulation analysis, Histogram, Pie chart or Text report can be generated. Select the desired
chart in the Chart/Report section.

e Press the Next button. Second page of the wizard appears.

e Ifthe analysis is based on recipe, the recipe range has to be selected. Specify the start and end
range for the recipe. The selected recipe names between the given ranges are shown in the selected
name(s) list for reference.

e If the analysis is based on components, select a recipe number. The corresponding recipe name is
shown nearby. All the components of the selected recipe will be shown in the report.

e Select the further options Date range and Graph Options.

e After selecting the report options, press the Finish button to generate the report.

The generated Formulation analysis report is shown.
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j- Totalizing / Pharma Formulation Reports

In Formulation, reports can be used to view weight details of Components. The steps to generate report
for Totalizing and Pharma Formulation are exactly the same.

To generate the report, the procedure listed below can be followed.

¢ Inthe FormTool Report Wizard screen, select the option Pharma Formulation/Totalizing.

e In Totalizing / Pharma Formulation analysis, Histogram, Pie chart or Text report can be generated.
Select the desired chart in the Chart/Report section.

e Press the Next button. Second page of the wizard appears.

e Components can be selected using the index. Specify the start and end range for components. The
selected component names between the given ranges are shown in the Selected name(s) list for
reference.

e Select the further options Date range and Graph Options..

e After selecting the report options, press the Finish button to generate the report.

The generated report is shown.

k. Individual queries with Advanced Reports

Queries can be designed manually and saved for future use.

To design a query, follow the steps below.
soL
o Select Advanced Reports from the View menu or press toolbar button. Advanced Reports
screen will appear.
e If Advanced Reports screen is invoked for the first time (i.e. if no queries are created previously), a

New Query dialog box will appear. Otherwise select New Query O button.

¢ In the New Query dialog box, select the query type from Report type drop-down (combo box) list. All
query types are described below.

e Enter the name for the new query.

e Enter the description for the query (optional) and press OK button. Query description can be up to a
maximum of 250 characters.

A new empty query will be created with the given name.

Depending on the report type selected, the field names listed in Advanced Reports screen will vary. In
the Advanced Reports screen, individual columns are shown with database fields and its
attributes/constraints (conditions). From these columns, the required fields and their constraints
(conditions) can be selected to form a query. See title named Query Design for more details about
designing a query.

Report type options and their descriptions are listed below:

1. Stored Formulation: Standard:
If this report type is chosen, reports for all the dispensed details in Vertical and Horizontal filling
modes can be produced.
2. Stored Formulation: Batch Dispensing
Reports for batch-dispensed details can be analyzed in this report type.
3. Stored Formulation: Formula Details
This report type can be used to produce reports on original Formula details in Formula database.
4. Stored Formulation: Raw Material Details
This report type can be used to analyze Raw Material details in Raw Material database.
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5. Stored Formulation: Messages
This report type can be used to produce reports analyzing Messages database.
6. Formulation
This report type can be used to produce the dispensed details of Formulation application.
7. Pharma Formulation
This report type can be used to produce the dispensed details of Pharma-Formulation application.
8. Totalizing
This report type can be used to produce the dispensed details of Totalizing application.

New Query dialog box is shown below.

Advanced Reports-New Query 1]
Creates a new guery of the selected type
Repart type IStored Farmulation-5tandard LI

Mame lSampIe1|

Drescription Dretailz of formula dispenzed in the last ;I
morith

E
ok I Cancel |

Query Design

In the Advanced Reports screen, each row can have a database field. The columns corresponding to a
row represents the attributes and constraints (conditions) of that field.

From these columns, the required attributes and constraints (conditions) can be selected. In the
Advanced Reports screen, clicking the left mouse button on each cell, allows to select the field
items/values.

Field Selection:

In the Advanced Reports screen, the column with title Field contains a list of field names displayed in a
tree structure.

Choose any field name in the tree structure and specify the required constraints (conditions).

Options 'Show', ‘Column name’ and 'Sort':

Option Show is used to enable or disable printing the corresponding field in the report. If this option is set
ON, then the field is printed in report. (By default, all fields have the Show option set ON).

Option Column name is used for customizable printout of the field name. User can edit the field name as
required. This name is used for printing. This text is editable only if Show option is set ON.

Option Sort is used to specify the order of arranging data in printout, whether in ascending or
descending order. A maximum of two levels of ordering is allowed namely, Primary and Secondary.

Both levels can be used in a query. In such cases, the data are first ordered by the 'Primary' sort field and
then by 'Secondary’.
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Constraints:

Constraints (conditions) are used to filter the data.

When designing a query, data can be retrieved based on the user requirement, like retrieving all data
matching a particular condition.

In a query one or more constraints can be used. The column Operators holds a list of relational operators
(=, <>, <=, >=, <, >, *). Please refer section Operators for more details on field dependent details on
operators.

An operator is used to relate (compare) the field value and the constraint.

Once an operator is selected from column Operators, the column Constraint1 is enabled. Then the
required constraint can be selected in that field. If the operator is not selected, no constraints can be
added.

Adding more Constraints:

Multiple constraints can be used in a query. For example, two conditions like "target > 1 kg AND target <5
kg" can be specified in a single query. By default two constraints were added.

To add more constraints in a query, right click the mouse on the index column in Advanced Reports
screen and select Add Constraint from the pop-up menu.

The column Condition holds a list of connectors (AND, OR). Please refer section Condition for more
details.

Deleting Constraints:

To delete a constraint, right click the mouse on the index column in Advanced Reports screen and select
Delete Constraints from the pop-up menu. All the added constraints (numbered from 3 to 10) will be
shown in another pop-up menu. Select any constraint to delete. The first two constraints cannot be
deleted.

Operators':

Operators are used to relate/compare a field value with a given value. The column Operators holds a list
of relational operators, depending on the type of active field. The following table lists field-type dependent
operators.

Field Type Operators

Text = <>
Others = <> <=, >=,<, >
'Condition':

Conditions are used to add multiple constraints. The column Condition holds two logical operators
namely AND and OR. These conditions can be used to add more constraints to the query.

If multiple constraints are used in a query, then, the order of executing the query will be on priority basis.
Two constraints connected by the AND operator is given more preference.

Running the Query

[=h
Finally after selecting the fields, the created query can be executed by clicking Run button in the
Advanced Reports screen. Before running the query, save the query. See title Saving a Query for more
details.

The generated report for the designed query is displayed.
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Advanced Reports window is shown below.

x
[=h g
I IR
Select Query ISampIe‘I ;I ¥ Show query
Feport Type: Stared Formulation-Formula DB

Index | Field | Show | Column name | Sort | [Cpd

1| Formula_Name Formula_Name Primary (A.Z) =

Raw_haterial_MName Raw_Material_Name

Raw_Material_ID
Target Weight
Tolerance

Raw_Material_ID Secondary ...
Target_Weight
Tolerance

Lo 8 N (o I

X ] €] ][] [<]

In Advanced Reports queries can be designed. Three examples for queries will be discussed on the
following pages of this document.

Saving a Query

Once the query is designed it can be saved for future reference. By clicking the Save = button in the
Advanced Reports screen, the query is saved.

Option 'Save As':

Option Save As is used to save the query with a different name.

e Press Save As Iﬁ button.

e Enter the new query name and description and press OK button.
The query will be saved with the new name.

Deleting a Query

If any saved query is not needed, it can be deleted.

&
By clicking Delete gbutton in the Advanced Reports screen, the selected query will be deleted.

Clearing current query

Active query shown in the Advanced Reports screen can be cleared by clicking the Clear EE button.
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Customize Option

By default, all the fields related to the selected report type will be shown in the Advanced Report
screen. User can eliminate some of these fields. In this case, the fields that are skipped by the user will
not be available in the list of fields shown in Field column in Advanced Reports screen.

The option Customize View in Settings menu can be used to customize the tables. The Customize W
toolbar button can also be used to customize the tables. This option will display the list of tables and their
corresponding fields. In this screen, fields can be selected or deselected for the active report type. The
primary key fields in tables cannot be deselected.

Select the report type from Report type drop-down (combo box) list. The corresponding tables will be

displayed with their filed names. Select or deselect the fields. Then pressing the button saves the

settings and closes the window. To exit without saving the settings press button.

The button g selects all the fields in the currently opened tables.
The button @( clears (deselects) all the fields (except primary key fields).
Customize dialog box is shown below.

X
¥ %% 9 @

Repart type IStDred Farmulation-Standard LI

i~ Fomula_Dispense - i Compound_Dispense i~ CompoundDispense_Muli_Charge

[ Dispensed Date

[ Dispensed_StanTime
[ Dispenzed EndTime
Farmuls_Mo
Farmulz_ID
Farmula_M ame

[ Lot_Mumber
Total_Compounds
Target_‘weight

O Tolerance

Dispenzed ‘weight
¥ Error Percent L!

Raw_Material Mame
[ Charge_ Mumber
Target_‘weight

O Tolerance
Dispensed ‘weight
Enor_Percent
Dispensed_Status
Start_Time

O 5cale_Id

Farmula_SNO =t Compounds_SNO Mutl_Charge SNO
ID7_UritlD Compound_Mumber Compound Mumber
UszerMame Raw_Material_ID Dispenzed_\wWeight

Charge Mumber
[ Dispensed_Status
Start_Time:

O 5eale ID

Report Display/Printing

By default, all the selected fields will be displayed in the report. If some fields have the Show option set to
OFF, then those fields will not be displayed.

By default, the constraint applied to fields will not be shown in the report. If the option Show Constraints
in Report Generator screen is enabled, then only those fields that are having constraint(s) will be shown.

The report display screen size will be adjusted according to the size of the report.

Once the report is displayed, it can be printed. Before printing, the report can be pre-viewed by selecting
Print Preview option in File menu.

Depending on Paper Size set in the Print Setup option in File menu, the report is printed in one or more

pages.
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Sample Queries

In Advanced Reports queries can be designed. Three sample queries are described below.

Sample 1

Query: Select all the compounds with a specified formula name
Steps:

o Open the database file by selecting Open from File menu. As soon as the file is opened, the
Reports Wizard appears.

¢ Invoke the Advanced Reports window by clicking Advanced Reports button in the Wizard.
Advanced Reports window will appear.

Click the New [ toolbar button. A New Query popup window will appear.
In Reports Type drop-down list, select the Stored Formulation - Formula DB.
Enter a name in the name edit box and its description.
Click Ok button to save the query. Refer Fig 1.
In the Field column of Advanced Reports window, select Formula Name, Raw_Material_Name,
Raw_Material_ID, Target _Weight of Compound and Tolerance of Compound all in separate
rows. Refer Fig 2.
¢ In Formula Name row select the '=' operator in operator column and in constraint1 column select
the desired Formula Name. Refer Fig 3.

B

e Click the Run #& toolbar button.

NEICEEE

> o

Select g . =
Advanced Reports-New Query. Zj
Report Ty
Creates a new queny of the selected type
Index I Field l Sort
Al =il Repart type lStored Formulation-5 tandard LI
2| Raw_| Mame |Sample1
3| Raw_| Description |Select all compounds of & given |
Farmula
4| Targe
-
5| Tolerz .4
B Cancel |
q : ]

Figure 1
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x
[=5 ;
S = |
DR PP e
Select guery ISampIe j V' Shaw query
Feport Type : Stored Formulation-Formula
Index | Field | Shiaw | Colurn narne | Sark
1| Formula_Narme Formula_Name
2| Raw_Material_Name Raw_Material_Name
3| Raw_Material_ID Raw_Material_ID
4| Target_Weight Target_vWeight
4|| Tolerance j Tolerance
6| & Index Al X
- Raw_Material_ID
- Raw_Material_Name
(| : : »
Pre_msg
- Post_msg
- Formula_|D —
- Formula_MName
- Target_weight
- Tolerance
.. Total_Caormpounds
- Pre msg 1 -
< | »
Figure 2
x
[=5 :
= |
N || B2 3P &
Select gquery ISampIe1 :] @ ¥ Show queny
Repart Type : Stored Formulation-Formula DB
| Sark | [Operatar] | [Constraint1] | [Condition] | [Cperatar]

Burger
Cheese

F1212

F9

Formulai
Formulas (¥

Figure 3

Sample 2

Query: Select all the compounds whose tolerance are < 5 % in a specified formula.

Steps:

o Open a database file by selecting Open from File menu. As soon as a file is opened, the Reports
Wizard appears.

¢ Invoke the Advanced Reports window by clicking Advanced Reports button in the Wizard.
Advanced Reports window will appear.

o Click the New [ toolbar button. A New Query window will appear.
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In Reports Type drop-down list, select Stored Formulation - Standard.
Enter a name in the name edit box and its description.

Click Ok button to save the query. Refer Fig 1.
In Field column of Advanced Reports screen select Formula_SNO, Formula_Name,

Compound_Number, Raw_Material_Name, Raw_Material_ID, Target Weight of compounds,
Tolerance of compounds, Dispensed_Weight of compounds and Error_Percent of compounds all

in seperate rows. Refer Fig 2.

e In Formula_Name row select the '=' operator in operator column and in constraint1 column select
the desired Formula Name. Refer Fig 2 and Fig3.
e In Error_Percent of Compounds row, select '<' operator in operator column and enter value '5' in

constraint1 column.
[=H

e Click the Run & toolbar button.

IEEIRIC)

Select g . = =
° x
Fepaort Ty
Creates a new query of the selected type
Index I Field | S0l
Report type ion- -
Bl port tp IStored Faormulation-5tandard _I
3| Farme Mame ISampIe2
3| Camp Description  |Select all compounds whose d
Eror_Percent < 5% in a specified
4| Raw | Farmula 3
8 Raw | ﬂ
6| Targe Ok, Cancel |
7| Tolerare &] ToErance
8| Dispensed_Weight Dispensed_wWeight
<1 | mE‘
Figure 1

DR R E S IPe

Select guery ISample 2 j Ej ¥ Show queny

Select all compounds

Repart Type : Stored Formulation-Standard
Index I :eld — |Sh0w |COIumn name inLa SPE;;(?;EP;J:;I;:: 5%
1| Formula_SNO Farmula_Shio
2| Formula_Name Formula_Name
3| Compound_ Number compound_Number
4| Raw_Material_Name Raw _haterial_Name
5| Raw_Material_ID Raw_Material_ID
6| Target Weight Target_Weight
7| Tolerance Tolerance
8| Dispensed_Weight Dispensed_Weight
7 | o]

Figure 2
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x
D E "R ® PP e

Select guery ISample 2 _v_I @I ¥ Show querny
Fepaort Type : Stored Formulation-Standard
| Sork l [Cperator] | [Constraint1] l [Zondition] | [Operal =

F1212
Farmulal
Formulag
Farmula?

Figure 3

Sample 3

Query: Select all formula dispensed where the target weight < 700 g and dispensed tolerance <5 AND >
0 and Dispensed_Date > 02/20/2002 and < 02/28/2002 which contain the certain compounds ‘Water’,
‘Sugar’ or ‘Lemon’ and lot number is not empty

Steps:

e Open a database file by selecting Open from File menu. As soon as a file is opened, the Reports
Wizard appears.

¢ Invoke the Advanced Reports window by clicking Advanced Reports button in the Wizard.
Advanced Reports window will appear.

Click the New O toolbar button. A New Query window will appear.

In Reports Type drop-down list, select Stored Formulation - Standard.

Enter a name in the name edit box and its description.

Click Ok button to save the query. Refer Fig 1.

In Field column of Advanced Reports window, select the Formula_SNO, Formula_Name

,Formula_ID, Target_Weight, Dispensed_Weight, Error_Percent, Lot_Number,

Compound_Number and Raw_Material_Name all in separate rows.

¢ In Raw_Material_Name row, select the '=' operator in operator column and in constraint1 column
select the Water, in condition column specify the OR operator, in operator column select '='
column and select the Sugar in Constraint2 column.

e Add a new constraint (refer Constraints in Query Design topic).

¢ In the new condition column specify the OR operator and select the Lemon in Constraint3
column.

e In Error_Percent of Formula row, select '<' operator in operator column and enter value '5' in
constraint1 column and in condition column specify AND operator and in operator column
specify the ">' operator which is next to condition operator and in constraint2 column enter the
value 0.

o In Dispensed_Date of Formula row, select '>' operator in operator column and enter value
desired in constraint1 column and in condition column specify AND operator and in operator
column specify the '<' operator which is next to condition operator and in constraint2 select the
desired date.

e In Lot Number of Formula row, select '<>' operator in operator column and do not enter
value in constraint1 column. Refer Fig 2 and Fig 3.

[=h
e Click the Run #3 toolbar button.
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Advanced Reports
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I. Saving Reports

Generated reports can be saved for future reference. It can be stored as a HTML file or an Excel file.

Saving as HTML file

Any type of report whether a graphical or text report can be saved as a HTML file.

Reports can be saved by selecting Save as html option from the File menu or by pressing " toolbar
button.

For a Histogram, Plot Graph or a Pie Chart, a HTML file is created with a folder containing the report
image. The image is created in JPEG format. The folder has its name “_files” added to the HTML file
name and it is present in the same location as that of the file.

For a Text Report, only a HTML file is created in the specified location.

The HTML file can be customized by using templates. See Using Templates for more details.

Saving as Excel file

Text reports can be saved as an Excel file. Graphical reports can only be saved as HTML file.

Reports can be saved as Excel files by selecting Save as xls option from the File menu or by selecting

il

toolbar button.

m. Accelerator Keys

Accelerator keys are shortcuts for reports. Frequently used reports can be assigned to an Accelerator
(Shortcut Key). These shortcut keys to reports are specific for a user. Thus, each user can generate and
save shortcuts for reports based on his/her specific needs. Accelerator keys are displayed in both MT-
FormTool and Reports main window. They can be shown/hidden by invoking the option Accelerator Keys
option in View menu in MT-FormTool and Reports.

To generator the accelerator key, follow the steps below,

1. Start Reports from Tools menu.

2. Design and produce a report using Wizard or Advanced Reports.

3. Click any Accelerator key 1-6 in Reports window and select Associate with current report. Then the
current report is stored and a message ‘Report is Stored’ is displayed.

Note:
Reports are stored based on the current user logged on to MT-FormTool. All user classes have a
maximum of six different accelerator keys.

Invoking Accelerator Keys:

Accelerator keys can be invoked in both MT-FormTool and Reports windows. In MT-FormTool window
clicking the Accelerator key containing the stored report will yield the same report in the reports window. In
Reports, clicking the Accelerator key containing stored report and selecting the menu option Execute
Store Report will produce the stored report.
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B Reports - Samplel.mdb i -100 x|

File Wiew Tools Settings Language Help
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Formula ID :F12
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Samplel.mdb Page:1 Prepared by Noel
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Accelerator Keys
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MT-FormTool: admin - Stored Formulation - [Samplel.mdb] ) _|EI|1|
File Users Yiew Tools Application Options Language Help
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MT-FormTool Accelerator Keys
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n. Using Templates

The Reports application uses a report template to structure and style reports. Report templates are HTML
files with Embedded Report Placeholders for the report data. When a standard template (Normal.html)
is used for saving a report, all the data like header, graph and footer are retained in the HTML file. By
default Normal.html file is used.

Note:
When MT-FormTool is installed, three html files will be copied (used as templates) in the templates
directory under the installation directory.

Custom Templates

A custom template is used when the content or style of the standard report needs to be changed. Using a
custom template user can create a report, which may contain only a subset of information generated from
a standard template or with required additional information like description.

Creating a Custom Template

Use a copy of the standard template (Normal.html) or any of the sample templates (Sample1.html or
Sample2.html) as a starting point to create custom templates. Here Embedded Report Placeholders may
be removed to exclude the corresponding report data and additional data such as description may be
added to the custom template. This copy can be altered to create a new design at user’s will.

Setting Custom Templates

After a custom template is created the settings of the Reports Wizard should be changed to make it use
the custom template instead of the standard template. This is done by selecting Set Report Template
option from the View menu.

Sample Templates

Two sample templates Sample1.html and Sample2.html files are provided to aid creation/understanding of
custom templates.

e Sample1.html adds a description to the report.

e Sample2.html adds a logo at the top right corner of the report. This logo can also be customized by
replacing the “logo.jpg” file with some other logo having the same name. This file is present in the
Templates directory.

o. Header / Footer Configuration

Header and Footer can be customized by choosing Header and Footer option from the View menu or by

E .
pressing ' toolbar button. Also by right-clicking the header/footer area in the generated report and
choosing the menu option will invoke the Header and Footer window.

The location has to be selected in the Header and Footer interface and desired option has to be clicked.

In Header and Footer window, select Insert Auto Text. A pop-up menu will be shown with the following
options.

Title:
Each report has a title given by the application. This title is shown for this option.
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File:
Reports are generated for a database file. The name of the database file is displayed for this option.

Page:
This option allows the user to know the page number of the report .It would be useful in the Text report
because only this report produces multiple pages.

Date:
This is the current date. The system date is taken for this option.

Time:
This is the current time. The system time is taken for this option.

Custom:
If any other text other than the above options is required, this option can be used. Here a separate
interface is provided to get the custom text. Custom text can be up to a maximum of 250 letters.

Clear:
This option can be used to clear the contents in the specified (selected) location.

The other options are,

Font:
This option allows the user to change the font of the text displayed for that particular location.

Restore default:
This option enables the user to restore the default header and footer settings if any.

Set as default:
This option sets the current header and footer configurations as the default setting.

The Header and Footer window is shown below.

x
r Customize header
|ate] ([Title] |
I Insert Auto Text Eont... I Restore default | Set as default |
T
Flle I I[Nu. of Records]
Pageho
s |[PageNu] Prepared hy Noel
Time
Mo, of Records
i ak. I Cancel |
Clear

p. Changing Fonts and Colors in Reports

In reports, the color of a bar (or a pie) and the background color of the graph area can be changed easily.

Changing the color of a bar/pie/plot:

To change the color, follow the steps below.
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1. Right-click on the appropriate bar or pie or plot-circle area. A pop-up menu will be displayed.
2. From the menu, select the option Change Color.
3. Select the desired color from the interface.

After changing the color, the default color of bar, pie or plot-circle can be retained by selecting the option
Default Color in the pop-up menu (Right clicking on the graph area will invoke a pop-up menu).

Changing the background color of the graph:
In Histogram and Plot graphs, the background area of the graph can be changed.

To change the background color, follow the steps below.

¢ Right-click on the graph’s background area. A pop-up menu will be displayed.
e From the menu, select Change Color option.

e Select the desired color from the interface.

The background area of the graph is filled with the selected color.

After changing the background color, the default color can be retained by selecting the option Default
Color from the pop-up menu, which is created by right clicking on the graph area.

Changing Fonts:

In reports, fonts of the displayed texts can be changed.

To change the font, follow the steps below.

¢ Right-click on the appropriate text area. A pop-up menu will be displayed.
e From the menu, select the Change Font option.

e Select the desired font from the interface.

The Default Font option from the pop-up menu is available for revert the changes.

q. Adding Tags
Tags act as a source of additional information for a graph. It can be easily added or removed from the
graph.

In graph, by right clicking the mouse on a bar or pie or a plot-circle, a menu will be displayed with an
option Add Tag. If this option is selected, a tag is added to the corresponding graph.

The tags can be removed from the graph. By right clicking the mouse on a tag-added bar or pie or plot-

circle, a menu with the option Remove Tag is displayed. Select this option to remove the tag from the
corresponding graph.

r.Printing Reports

The generated report can be taken as a printout. It can be done by selecting Print option from the File

menu or by pressing Print S toolbar button.

The standard Print dialog box lets you choose which printer should be used, how many copies are printed,
whether to print in landscape or portrait mode, etc.
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The Print Preview option in the File menu shows the preview of the report. The toolbar button can
be used to preview the report.

s. Linear/ Non-Linear Scales

Depending on the range of values, the histogram report can have linear or non-linear scale along y-axis.

In linear scale, each scale unit will be incremented with an absolute value.
In non-linear scale, each scale unit will be incremented proportionally, where scale is logarithmic.

t.Impact on modifying database

When the Stored Formulation (Formula, RM and Message) database is modified, it may affect the reports
based on Stored Formulation. When the existing database has to be modified, it is advisable to create a
new file and then make necessary changes and update the changes to ID7. The Stored Formulation
database alone can be exported/Imported to/from external database files.

Reports may be affected and possibly incorrect when any of the following changes are made in Stored
Formulation database:

Modifying Formula name

Modifying Raw material name

Deleting formula

Deleting raw material

Altering formula compounds (Deleting, adding and modifying formula compounds)

Exporting Database:

Exporting database will copy the Stored Formulation tables to the given database file from the currently
opened file. Save As option copies the entire set of tables including Transaction records, where as Export
will copy only Stored Formulation tables- RM Table, MSG Table and Formula Table. You can open the
newly exported file as any other database file.

The following procedure can be used to export database contents.

1. Open the existing database file where the formula / raw material details have to be changed.

2. Select Export from the File menu.

3. Enter NEW file name and press Save button. The DB Configuration contents will be exported to this
file.

Importing Database:

Import database option will copy the Stored Formulation tables from the given database file to the
currently opened file. For importing database, the corresponding tables in the current file should be empty.
That is, a new set of Stored Formulation Tables cannot be imported into a Database file that has these
tables established. The import operation is allowed only once — when a New Database File is opened
(after File->New operation).

The following procedure can be used to create a new file with exported database contents.

1. Create a New Database File.
2. Select Import from the File menu and Import the saved DB Configurations.
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3. The Stored Formulation tables will be imported from the existing database file to the new file.
4. Now change the database contents in the new file and download (or sync) this file to ID7 and start
using this file.

Note:

When there are no dispensing details in the database file, you can change the database as you want
because there are no dispensing details and therefore reports are not affected.

7. ID7 Display Panel

If MT-FormTool is connected with ID7, the ID7 display panel shows the current scale weight, scale unit
and scale id. If the scale weight is dynamic, then the ‘~’ symbol is shown instead of the scale unit.

Changing Foreground and Background Colors:

In the display panel, the foreground and background colors can be changed.

To change the color, follow the steps below.

1) Press the mouse right button on the display panel. A menu appears with BackColor and ForeColor
options.

2) Select any one option. The color dialog box will appear.

3) Choose the desired color and press OK button.

The display shows the corresponding background color and foreground color. When the application is not
connected with iD7, you may not be able to see the foreground color since there is nothing to display.

Hide/Show Panel

The ID7 display can be made hide/visible by selecting Panel option from the View menu.

8. Multi-Lingual support

MT-FormTool application supports multi-lingual feature.
It provides six languages that are listed below:

German
English
French
Dutch
Italian
Spanish

OO WN -
== ——

To change the language, select any one of the available six languages from the Language menu. The
application will show all the texts (including menu items) in the selected language. The current language is
shown with a tick symbol in the Language menu. When the application starts the next time, all the texts
will be shows in the selected language.
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9. Managing Sessions

Multiple instances of MT-FormTool can manage multiple ID7 terminals. All the data collected by these
instances can be logged on to a single or multiple database files. The following diagram (Figure-1) shows
the multiple instances running and all the data collected are logged on to a single database file.

PC FotmTool-XP
Instances

Instance 3 [~

fiffer-1

The above diagram (Figure-1) has three instances of MT-FormTool connected with three FormPac ID7
terminals and all the data collected by these three instances are logged on to a single database file. Here
single database file manages all the data of three ID7 terminals.

1071 FormTaal-XP PC FormTool-Xp D74
Instances Instances

DE DE
e e
f—4 [

ID7-B
File_sxy. mdb Filz_ab mdb

=

Instance ' Instance B

Tiffer-2

The above diagram (Figure-2) has four instances of MT-FormTool connected to four FormPac ID7
terminals. Data collected by the instances A & B is logged on to the File_ab.mdb and data collected by
instances X & Y are logged on to the File_xy.mdb. Here two different database files manage the four ID7
terminals.
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10. Updating Stock

MT-FormTool maintains the stock values for the raw materials if the Track Inventory option is enabled.
This feature is useful when multiple FormPac-XP units are tracked on the same system using a single
database file. Whenever a compound is dispensed, its stock value is updated within the ID7 and also in
the database (.mdb file) maintained in the PC. In case of multiple ID7s using the same store, the stock
value maintained by the FormPac-XP on ID7 may not be correct as they do not account for the usage of
raw-materials by other FormPacXP units. Therefore it is necessary to correct the stocks on ID7
periodically with the correct value tracked by FormTool.

To update the stock values on FormPac-XP from the values tracked by FormTool, click the Stock toolbar
button in DB Configuration window. Select Update Stock from the pop-up menu. A confirmation message
will be displayed. And if the TIDs (Table Ids) of the current database are not the same as TIDs in ID7, then
a warning message will be issued.

If Enable Store option is enabled (via Inventory Control option from the View menu), then stock values
will be taken from the corresponding store. Otherwise stocks will be taken from the raw materials
database.

Note:

The stock value is updated locally in the database file only if Track Inventory option is enabled. To
enable Track Inventory, select Inventory Control from the View menu. From the Inventory Control dialog
box, check the Track Inventory option.

11. Inventory Control

Inventory control tracks stocks in all the ID7 terminals associated with the current database file. Stocks of
ID7 terminals can be managed individually, or in groups, or ignored. Inventory is managed by the
Inventory Control window, which can be selected from the View menu.

Inventory Control Window:
Inventory control has Track Inventory option. Multi Stores or Groups can be managed by activating
‘Enable Stores’ option under this control.

Inventory tracking:
Track Inventory and Enable Stores options:

1) If ‘Track inventory’ option is disabled, then stocks of Raw Materials are not updated on dispensing.
They are ignored.

2) If ‘Track inventory’ option is enabled and ‘Enable Stores’ option is not enabled, then all the ID7
terminals belonging to the current database file are considered as a single group and the stocks
values of the Raw Materials are updated during dispensing as the raw-materials are consumed. If the
original stock levels are incorrect, it is possible that the inventory values become zero or even
negative when the raw materials are consumed during formulation

3) If ‘Track inventory’ option is enabled and ‘Enable Stores’ option is also enabled, then Stocks of
Raw Materials can be managed in Stores (groups otherwise). Stores are nothing but a group of ID7
terminals. There can be up to 10 Stores within a database file and each store can have up to 10 ID7
terminals. So stocks of 100 ID7 terminals can be managed from a single database file.
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Store Details

Details of the stores can be viewed in table below the Store Details text in inventory control window. The
table shows the list of ID7 terminals and their assigned stores. Each ID7 terminal can be assigned to any
available store by simply clicking the required store cell in Store Column and selecting the desired Store
from the list of stores. New stores can be added by clicking Add Store button and by entering the name of
the store (Store name cannot contain spaces, instead of spaces underscore or other characters can be
used). The newly added store is available in Stores list of the Stores column.

Connection Details

When Track Inventory and Enable Stores options are enabled, then on connecting with ID7 terminal,
Terminal Id of ID7 is read and checked the list maintained for each store in the database file. If the ID7
terminal does not belong to any of the stores or if there are no stores in database file, then Assign Store
window is prompted.

Assign Store window can be used to assign the currently connected ID7 terminal to any one of the
available stores or to a new store.

e The list of available stores is shown in the Assign Store list

e New store can be created by clicking the New Store button and by entering the name of the new store
(Store name cannot contain spaces).

e Select the store name from the list.

e If you don’t want to assign a store for the connected terminal, just select the empty store name
available in the list.

e Press OK button.

Now the selected store will be assigned to the connected ID7 terminal. If Cancel button is pressed, no
store will be assigned. Later, stores can be altered by choosing Inventory Control from the View menu.

Inventory Control x|

¥ Track Irvventany

¥ Enable Stores
Store Details :
Terminal ID | Stares -
Unitl  Storel
Unitz | Store 3 LI:|
Unit4 -
__|Storel
HNi | Store 10 3
AStore2
oK. Stored =

Inwentory Caontrol

Editing Current Store

DB Configuration window shows the store as stock. If the MT-FormTool is connected to an ID7 terminal
and if Enable Stores option is enabled, then Raw Materials table in DB Configuration window shows the
Store (Stock) values (in the stock column) that the current ID7 terminal belongs to.

Updating Stock (for current store)

Updating stock to ID7 is writing stock details of Raw Materials from the MT-FormTool to ID7 terminal.
Stock values for the current store can be updated by clicking the Stock toolbar button in DB Configuration
window and selecting the Update Stock option from the pop-up menu. The stock values are updated
accordingly.
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Editing All Stores

All the stores in database file viewed together. To view all the stores click ‘Stock’ button and select the
‘View all stores’ option form the menu in DB Configuration window. All the stores are shown and each of
the stores can be edited individually but Raw material id and its name are not allowed to change. Raw
materials can be viewed again by clicking ‘Stock’ button and deselecting the ‘View all stores’ menu

option.

Other cases:

No Connection and Track Inventory and Enable Stores are enabled

If there is no connection with ID7 terminal, ‘“Track Inventory’ and ‘Enable Stores’ options are enabled, then
store shown in Raw Materials table of DB Configuration window will be empty, since the MT-FormTool
does not know which available store to show. So stock value cannot be updated in Raw Materials table.
However the stock value can be updated using the option ‘View all Stores’ in Stock button. So on a
disconnected status and the above options are enabled, use the ‘View all Stores’ option to change
the stock value.

Note:

Inventory control doesn’t keep track of consumed quantity in Raw Materials table. It reflects the quantity
last read from ID7.

12. User Management

User management determines the level of access to the MT-FormTool. User management prevents users
from making careless mistakes. There are 3 different types of users namely Administrator, Supervisor and
Operator. The access rights for the users are shown in the following table.

View DB/ | DB Creation/ | Edit DB Download/ View Inventory User

Logging Open/Save Upload Reports Control Management
Operator Yes No No Yes Yes No No
Supervisor Yes Yes Yes Yes Yes Yes No
Admin Yes Yes Yes Yes Yes Yes Yes

The administrator manages users.

To add new user, follow the steps below

SRl

To set password to a user follow the steps below

Select User Settings in the User menu. The User Settings dialog appears.

Select User Settings in the User menu. The User Settings dialog appears.

Click the Add button.

Enter the user name and access privilege. (Only Supervisor and Operator privilege can be set)
The administrator can view the user rights by clicking the View Rights button.
Click the OK button

1.
2. Select the user in user name table and click the Set Password button.
3. Enter new password and confirm the new password in the pop up window. (Old password is not

needed)

4. Click the Done button to update the changes
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Only the administrator can change the password for other users. All the other users are allowed to change
their own password alone. If the administrator changes his/her own password then old password is
prompted. The user name is 30 characters and password size is 10 characters.

The administrator can add/modify/delete the users. Deleting the user deletes the user with all the
accelerator key reports for that user. The administrator can modify the access privilege for the other users.
The administrator name cannot be changed. There can be 1 administrator, 2 supervisors and 5 operators
fora PC.

When Login dialog displayed:

When the MT-FormTool is installed, there will be only one user (that is admin) and no password is set for
admin. In this case, login dialog won’t be displayed. In this case, the user name will be taken as admin.
When the admin changes the password or if more users are added, then login dialog will be displayed
every time the application starts.

How to logon:

The current login name will be displayed in the window title along with the application name (If no user
name is displayed, then it means no user has logged in).

1. Select Logon option from Users menu. Login dialog will be displayed.
2. Enter the user name and password. If successfully logged in, then current login name will be shown in
the window title.

How to logoff:

Select Logoff from Users menu. If the user is logged off, the MT-FormTool will be disconnected from ID7
and it will try to close the reports window if any opened.

Note:
User logging information is stored in the file ‘logfile.txt’ in the MT-FormTool installation directory. The

option Clear logged Info in the Tools menu will delete this file and the connection status (Session
Information) in the database file.

13. Error messages

The following are the possible error messages shown by MT-FormTool and the description of the error
message.

Communication Error Messages

Connection failed

The specified PC port may be connected with other application. Verify the PC port with which ID7 is
connected and change the PC port number by selecting Interface Settings from the Options menu or

pressing Settings toolbar button. Then connect again by selecting Connect from the File menu.

Cannot establish connection with the system

The specified IP address is not correct or the Ethernet port number is not correct. Verify the Ethernet IP
address and Ethernet port number in ID7 and change the Ethernet settings by selecting Interface

Settings from the Options menu or press Settings k=l ) toolbar button.
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No response from ID7

If the COM-Port (PC Port) settings are wrong or if the ID7 terminal is not connected with PC, this error
message is shown.

Make sure that the ID7 terminal is connected with the PC and it is switched on. Verify the interface
settings both in ID7 and in MT-FormTool. Change the interface settings (baud rate, data bits, parity, stop
bits and Frame String [CR, LF, STX_ETX and CheckSum] options) so that interface settings are same

both in ID7 and in MT-FormTool. Now select Disconnect E from the File menu and select Connect =)
to connect again.

BasePac/FormPac version error

If the Pac (bin) version in ID7 is not compatible with the MT-FormTool, this error message is shown. MT-
FormTool is designed for FormPac-XP Version 2.08. Download the correct Pac (bin) and connect with
MT-FormTool again.

At sometimes due to some communication problems, this error message is shown. In those cases just
disconnect and connect with ID7 again. If the same error message is repeated, then try changing the PAC
in ID7.

The unit is already monitored by the MT-FormTool

If an ID7 terminal is connected by the MT-FormTool and if another instance of MT-FormTool is trying to
connect with the same ID7 terminal, this message will be shown. Multiple instances of MT-FormTool
cannot monitor the same ID7 terminal.

File Error Messages

Unable to open the file. The file may be corrupted or invalid.

If the file is not created by the tool or if the database file format is different, then this error message is
shown. Open a valid database (.mdb) file or create a new database file by selecting New from File menu.

Error occurred while saving

If the given file in the Save As dialog box already exists and is used by some other application, this error
message is shown. Either close the other application that uses the file or give a different name and save
again.

Error occurred while creating new file

If the file name entered in the ‘New’ dialog box already exists and if it is used by some other application,
then the tool cannot create a file with the same name. Enter some other name or close the other
application that uses the file.

14. Database Structure

The tables used in MT-FormTool are categorized into five groups as shown below. The database schema
structure for each of the following table is explained with all field details. Select the category to view its
table structure.
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DB Configuration Tables

Stored Formulation Dispensing Tables
Formulation Tables

Pharma Formulation Tables

Totalizing Tables

The relationships between the tables are shown below.

Relationship between Stored Formulation Dispensing tables
Relationship between Stored Formulation Batch-Dispensing tables

1)
2)
3) Relationship between Formulation Application tables
4)

Relationship between Formula and Formula-Trailer tables (used in DB Configuration)

a. DB configuration Tables

In this section, tables related to DB Configuration database are listed. There are four tables in this section.

They are listed below.

Formula
Formula_Compounds
Raw_Materials
Messages

A ON -
== ——

Schema structure for Formula table:
Table name: Formula

No | Field Name Type Size | Comments

1 Index Long 4 Auto increment number

2 Formula_ID Text 11 Formula ID (Unigue)

3 Formula_Name Text 31 Formula Name

4 Target_Weight Text 15 Formula Target (designed) Weight

5 Tolerance Integer 4 Formula Tolerance: Addition of compound
tolerances.

6 Total Compounds Integer 4 Total no of compounds for a formula.

7 Pre_msg 1 Integer 4 Pre Message-1

8 Pre msg 2 Integer 4 Pre Message-2

9 Pre_msg 3 Integer 4 Pre Message-3

10 Post_ msg 1 Integer 4 Post Message-1

11 Post msg 2 Integer 4 Post Message-2

12 Total_Dispensed_Weight | Text 16 Total dispensed weight

13 Total_Cleared_Date Date/Time | 8 Total Cleared Date: Date at which formula total is
cleared.

14 Total_Cleared_Time Date/Time | 8 Total Cleared Time: Time ate at which formula total
is cleared.

15 Status Integer 4 Formula status in ID7 can be either Edit mode or
Complete mode or Invalid. (not used generally)

16 Valid Integer 4 For internal use.

17 Edit Status Integer 4 For internal use.
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Schema structure for Formula table:

Table name: Formula Compounds

No | Field Name Type Size | Comments

1 Formula_ID Text 30 For internal use

2 Raw_Material ID Text 21 Raw Material ID

3 Raw_ Material Name | Text 31 Raw Material (Compound) Name
4 Target Weight Text 15 Compound target weight

5 Tolerance Integer | 4 Compound Tolerance weight

6 Pre_msg Integer | 4 Pre Message

7 Post_msg Integer | 4 Post Message

8 Id Integer | 4 Foreign key from Formula table
9 Edit Status Integer | 4 For internal use

Schema structure for Raw Materials table:

Table name: Raw Materials

No | Field Name Type Size | Comments

1 Index Integer 4 Auto increment number

2 Raw_Material ID | Text 21 Raw Material Id

3 Description Text 31 Raw Material Name

4 Stock Text 15 Raw Material stock

5 Warning Integer 4 Warning

6 Msg NO Integer 4 Message No

7 Used Count Integer 4 Raw Material Used Count

8 Consumed Text 15 Raw material consumed

9 Stock Date Date/Time | 8 Stock updated date

10 Stock_Time Date/Time | 8 Stock updated time

11 Edit_Status Integer 4 For internal use
Schema structure for Messages table:
Table name: Messages

No | Field Name Type Size | Comments

1 Index Integer | 4 Auto increment number

2 Description Text 30 Message text

3 Edit_Status Integer | 4 For internal use

b. Stored Formulation Dispensing Tables

In this section, tables related to dispensing section of stored formulation are listed. There are five tables in
this section. They are listed below.

A WN -
=== ——

Formula_Dispense
Compound_Dispense
CompoundDispense_Multi_Charge
CompoundDispense_Batch
CompoundDispense_BatchDetails
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Stored Formulation Dispensed Formula Details Header

Table Name: Formula Dispense

No | Field Name Type Size | Comments

1 Formula_SNO Long 4 Auto increment number

2 ID7_UnitID Text 21 Terminal ID from ID7

3 UserName Text 20 User name

4 Dispensed Date Date/Time | 8 PC- Date: Dispensed start date

5 Dispensed_StartTime | Date/Time | 8 Dispensed Start Time: Start of formulation

6 Dispensed_EndTime Date/Time | 8 Dispensed End Time: End time when formulation
is done

7 Formula_No Integer 2 Formula number

8 Formula_ID Text 11 Formula ID varies from [1-150]

9 Formula_Name Text 31 Formula name

10 Lot Number Text 21 Lot Number: Optional - user entry at ID7

11 Total_Compounds Integer 2 Number of compounds in a formula varies from [1-
100]

12 | Target_Weight Text 15 Ideal target of formula

13 Tolerance Float 4 Tolerance weight +/- limits

14 Dispensed Weight Text 15 Total dispensed weight of compounds

15 Error_Percent Float 4 Dispensed Tolerance weight percentage.
Deviation from Target (+/-)

16 Tare Weight Text 15 Tare Weight

17 | Total_Batches Integer 2 Number of batches for a formula

18 Formula_Status Integer 2 Formula Dispensed status (Dispensed, parked,
cancelled or interrupted)

19 Flag_Byte Text 101 For internal use

20 Split Count Text 101 For internal use

21 Code _C Key Text 31 C key read from ID7

22 Code D Key Text 31 D key read from ID7

Stored Formulation Components Details Trailer

Table Name: Compound Dispense

No | Field Name Type Size | Comments

1 Compounds_SNO Long 4 Auto increment number

2 Compound_Number Integer 2 Compound number varies from (1-100)

3 Formula_SNO Long 4 Foreign key from formula table

4 Raw_Material_ID Text 21 Raw Material ID (Unique)

5 Raw_Material_Name Text 31 Raw Material Name

6 Charge_Number Text 21 Charge Number: Optional-user entry at ID7

7 Target Weight Text 15 Ideal weight of the compound

8 Tolerance Float 4 compound Tolerance Wt +/- Limits

9 Dispensed_Weight Text 15 Dispensed weight of the compound

10 Error_Percent Float 4 Dispensed tolerance: Deviation from Ideal
Target weight

11 Dispensed_Tolerance2 | Float 4 Dispensed Tolerance?2

12 Dispensed_Status Byte 1 Compound dispensed status: Shows whether
compound was dispensed manually or through
scale

13 Start_Time Date/Time | 8 PC-Time: Dispensing start time of the compound

14 Scale_lId Integer 2 Scale Id: Shows in which scale the compound
was dispensed
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Compound Dispense Split table

Table Name: CompoundDispense Mutli Charge

No [Field Name Type Size [Comments
1 |Mutli_Charge_SNO |Long 4 Auto Increment Number
2 |Compound_Number |Integer 2 Compound Number
3 |Compounds_SNO |Long 4 Foreign key from CompoundDispense table
4 |Dispensed_Weight [Text 15 Split dispense weight
5 |Charge_Number Text 21 Split charge number
6 |Dispensed_Status |Text 1 Shows whether compound dispensed manually or through
scale
7 |Start_Time Date/Time |8 Start time of dispensing
8 |Scale_ID Integer 2 Scale Id: Shows in which scale the compound was dispensed

Stored Formulation Batch Details Trailer

Table Name: CompoundDispense Batch

No | Field Name Type Size | Comments

1 Batch_SNO Long 4 Auto Increment Number

2 Compound Number Integer | 2 Compound Number [1-100]

3 Formula_SNO Long 4 Foreign key from formula table

4 Raw_Material_ID Text 21 Raw Material ID

5 Raw_Material_Name | Text 31 Raw Material Name

6 Charge_Number Text 21 Charge Number: Optional user entry at ID7
7 Target Weight Text 15 Ideal weight of the compound (Target Wt)
8 Tolerance Float 4 Compound Tolerance Wt +/- Limits

Stored Formulation Batch Weight Details:

Table Name: CompoundDispense BatchDetails

No | Field Name Type Size | Comments

1 BatchDetails SNO Long 4 Auto Increment Number

2 Batch_SNO Long 4 Foreign key for formula table

3 Dispensed_Weight Text 15 Compound dispensed weight

4 Error_Percent Float 4 Dispensed Tolerance: Deviation from Ideal
Target weight

5 Dispensed Tolerance2 | Float 4 Dispensed Tolerance2

6 Tare Weight Text 15 Container weight

7 Batch_ID Text 21 Batch Id of current batch

8 Start_ Time Date/Time | 8 Dispensing start time of compound

9 Scale_Id Byte 1 Scale Id: Shows in which scale the compound
was dispensed

10 Batch No Integer 2 Iteration number [1-100]
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c. Formulation Tables

In Formulation application, two tables are used. They are listed below.

1) Formulation_Container
2) Formulation_Compounds

Schema structure for Formulation Container table:

Table name: Formulation Container

No | Field Name Type Size | Comments

1 Container_ SNO Integer 4 Auto increment number

2 Recipe _Name Text 31 Recipe Name

3 Container_Weight Text 15 Container weight

4 Tare Weight Text 15 Tare weight

5 Dispensed_Date Date/Time | 8 Dispensed Start Date

6 Dispensed_StartTime | Date/Time | 8 Dispensed Start Time: Time when container is
loaded

7 Dispensed_EndTime Date/Time | 8 Dispensed End Time: End time when container is
closed

8 Code B _Key Text 31 B key read from ID7

9 Code D key Text 31 D key read from ID7

Schema structure for Formulation Compounds table:

Table name: Formulation Compounds

No | Field Name Type Size Comments

1 Container_SNO Integer 4

2 Compound No Integer 4 Component number varies from [1-15]

3 Compound Name Text 21 Component name

4 Compound_Weight Text 15 Component weight

5 Dispensed_StartTime Date/Time 8 Dispensed Start Time for compound

6 Dispensed_Status Integer 4 Component dispensed status: Shows
whether component was dispensed
manually or through scale

7 Scale_ID Integer 4 Scale Id: Shows in which scale the
compound was dispensed

d. Pharma Formulation Tables

In Pharma Formulation only one table is used. The schema structure for Pharma Table is listed below.
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Schema structure for Pharma Table:

Table name: Pharma Formulation

No | Field Name Type Size | Comments

1 Pharma_SNO Integer 4 Auto increment number

2 Component_Name Text 31 Component name

3 Component Weight | Text 15 Component weight

4 Tare Weight Text 15 Tare weight

5 Start_Date Date/Time | 8 Dispensed Start Date for compound

6 Start Time Date/Time | 8 Dispensed Start Time for compound

7 Dispensed_Status Date/Time | 8 Component dispensed status: Shows whether
component was dispensed manually or through
scale

8 Scale_ID Integer 4 Scale Id: Shows in which scale the compound was
dispensed

9 Code_A_Key Text 31 A key read from ID7

10 Code B _Key Text 31 B key read from ID7

11 Code D Key Text 31 D key read from ID7

e. Totalizing Tables

In Totalizing application only one table is used. The schema structure for Totalizing table is listed below.

Schema structure for Totalizing Table:

Table name: Totalizing

No | Field Name Type Size | Comments

1 Totalizing_SNO Integer 4 Auto increment number

2 Component Name Text 31 Component Name

3 Component Weight | Text 15 Component weight

4 Dispensed Date Date/Time | 8 Component dispensed date

5 Dispensed Time Date/Time | 8 Component dispensed time

6 Dispensed_Status Date/Time | 8 Component dispensed status: Shows whether
component was dispensed manually or through
scale

7 Scale_ID Integer 4 Scale Id: Shows in which scale the compound was
dispensed

8 Code_A_Key Text 31 A key read from ID7

9 Code B Key Text 31 B key read from ID7

10 Code D Key Text 31 D key read from ID7

15. Uninstalling the software

There are two ways to uninstall MT-FormTool.

1.

From the Start menu click Programs, then Mettler Toledo, and then Uninstall MT-FormTool.
2. Activate the Control Panel (Start Menu -> Setting -> Control Panel), double click Add/Remove
Programs, and double click on the MT-FormTool list box entry.
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16. Glossary

Terms used in MT-FormTool

Actual/Dispensed Tolerance Weight, Delta, Error
Difference between the Actual and Target weight of a compound

Actual Weight
Dispensed compound weight

Batch Filling
One of the dispensing modes in Stored Formulation application that is used to dispense each compound
in a formula "n" times iteratively, thus resulting in "n" batches.

Cancelled
Message text in MT-FormTool indicating that the dispensing has been cancelled in the middle of
dispensing.

Charge Number
Additional information-text pertaining to each compound in a formula, provided for user-entry when each
compound is selected for dispensing.

Connected Terminal Id
Active ID7 terminal for which the monitoring is in progress

Consumed
Used weight of the active Raw Material

End Time
Time when a formula is dispensed completely.

Expand
Option to view compounds in enlarged window

Formula
This is the actual stored formula. A formula can contain up to 100 compounds, each using a Raw Material
and having individual target and tolerance values. The formula database can store up to 150 entries.

Formula ID
Abbreviation for Formula Identifier (Alphanumeric text of maximum 10 characters)

Formula Name
Name of the stored formula (Alphanumeric text of maximum 30 characters)

Histogram
Graphical bars showing dispensed parts.

Horizontal Filling
One of the dispensing modes in Stored Formulation application that is used to dispense the compound in
the formula in individual containers.

Interrupted
Message text in MT-FormTool indicating that the monitoring has been interrupted in MT-FormTool.
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Linear scaling
In linear scaling, each scale unit will be incremented with an absolute value.

Lot Number
Additional information-text pertaining to a formula, provided for user-entry when a formula is selected.

Message
These are texts/actions for user notification during dispensing a formula in Stored Formulation.

MSG Id (Message Id)
Abbreviation for Message-Number in the message database. Valid range is 1 to 200. '0' indicates that no
message is used.

Non-linear scaling
In non-linear scaling, each scale unit will be incremented proportionally, where each proportion is
logarithmic.

Panel
MT-FormTool Window at the top, in which ID7 screen is simulated

Pie Chart
Graphical sectors showing dispensed parts.

Post (Msg)
Indicates Post-Formula or Post-Compound Message

Pre (Msg)
Indicates Pre-Formula or Pre-Compound Message

Progress Bar
Graphical bars showing dispensed parts.

Raw Materials (RM)
These are items that the stored formula uses. Raw Materials are stored in a database that can store up to
500 Raw Materials.

Read
Command to Read Stored Formula databases from ID7

Report Wizard
Tool that generates reports for monitored details.

RM Description (RM Name)
Abbreviation for Raw Material Name (Alphanumeric text of max. 30 characters)

RM Id
Abbreviation for Raw Material Id. (Alphanumeric text of max. 20 characters)

Send
Command to Write Stored Formula databases to ID7

Shrink
Option to view compounds in minimized window

Split Dispensed Weight
Partial dispensed weight of a compound
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Start Time
Time when a formula or compound has been invoked for dispensing

Stock
Remaining Stock of the active Raw Material

Stock Date/Time
Date and Time when stock was updated for the active Raw Material

Stored Formulation

One of the applications in FormPac-XP that supports formulation and dispensing. This application
supports three dispensing modes namely VERTICAL, HORIZONTAL and BATCH fillings. Features like
scaling a stored formula, rescaling on error generation and saving & restoring of a formula are available.

Synchronization (Sync)
Method to update changes done in MT-FormTool in ID7

Tags
Tags act as a source of additional information for a graph.

Target Weight
Target weight of the compound for the stored formula.

Templates
Template determines the content or style of the report.

Terminal Id
ID7 terminal to which the active formula belongs.

Tolerance Weight
Tolerance of the compound for the stored formula.

Used Count
Usage count of the raw material by the formulae

Vertical Filling
One of the dispensing modes in Stored Formulation application that is used to dispense all the
compounds in the formula in a single container (vertically).

Warning
Stock warning pertaining to active Raw Material
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