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MT-FormTool © is a companion product of FormPac-XP on ID7. It is designed to run on the following 
Microsoft platforms: Windows-98, Windows2000 and Windows XP. MT-FormTool uses Microsoft Access 
97 for accessing the database. However it is not necessary to install MS Access on the PC if it is not 
already installed. The necessary components for creating and accessing MS-Access compatible files are 
packaged with the FormTools. The main features of MT-FormTool are listed below: 
 
FormPac-XP Configuration Support (for Stored Formulation application) 
 
• MT-FormTool supports design of Formula, creation and maintenance of Raw Material Table and 

Message Tables (for Stored Formulation application) easily on the PC and to download them to ID7. 
These tables (database) can be saved on the local PC for subsequent use. FormTool can also read 
the existing databases from ID7, which can be saved on a PC. In case of updates to any of the tables, 
where only part of the database is modified, the “Sync” option provides convenient and fast 
mechanism for synchronizing the PC-based database with FormPac-XP on ID7. 

 
Process Monitoring and Visualization (for all applications of FormPac-XP) 
 
• MT-FormTool can be used to monitor the FormPac-XP dispensing details in real-time. It stores the 

dispensing details of all the four applications of FormPac-XP: Formulation, Pharma-Formulation, 
Totalizing and Stored-Formulation.  

 
Reports (for all applications of FormPac-XP) 
 
• MT-FormTool has capability to provide a wide range of reports, based on the data collected during 

FormPac-XP operation. Report Generation Wizard is used to generate graphical and text reports, 
based on the dispensed details of all the four applications. It provides various analysis for all the four 
FormPac-XP applications. Data can be displayed graphically in several formats: Tables, Histograms, 
Pie Charts or Graphs. The reports can be saved (as HTML files or Excel files) and also printed. 

 
Multi-Instance Support 
 
• An instance of MT-FormTool on a PC can be connected to one ID7 terminal that runs FormPac-XP to 

track the operations. Multiple instances of the tool can be invoked to track multiple FormPac-XP 
terminals and the data can be logged to a single database file for consolidation of results. The identity 
of each ID7 terminal is maintained by assigning a unique Terminal-Id to every instance of FormPac-
XP. Reports can be generated for each terminal or for all terminals from which data was collected. 

 
User Management 

 
• User management determines the level of access to the MT-FormTool. There are 3 different types of 

users namely Administrator, Supervisor and Operators. There can be 2 Supervisors and 5 Operators. 
The Administrator has all the rights where as the Supervisors and Operators are restricted to some 
operations. While Supervisor-level user can change and update Database records on FormPacXP, 
Operators are only allowed to log data and produce reports. Whereas user with Administrator privilege 
can setup new database tables and terminals. 

 
 
 
 
 
 

1. Introduction to MT-FormTool
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Inventory Control 
 

• Inventory control tracks stocks in all ID7 terminals associated with the current database file. Stocks of 
the ID7 terminals can be managed individually, all together or in groups or even be ignored. And the 
option ‘Update Stock’ can be used to update the stock values alone on the ID7. 

 
Multi-Language Support 
 
• Multi-Lingual support is available for the following languages. 

 
1. German 
2. English 
3. French 
4. Dutch 
5. Italian 
6. Spanish 

 
Whenever the application starts, it will try to connect to the ID7 terminal. 
 
• When the application starts for the first time, Interface Settings dialog box will appear with the 

standard settings. Specify the interface parameters and press OK button. Now, the application will try 
to connect to ID7. The status bar will show the current status of the application. 

 
If there is no response from ID7 or if the communication settings are wrong, error message will be shown. 
In this case, correct interface settings have to be provided. 
 
1) Now, disconnect from ID7 by selecting Disconnect option from the File menu or press Disconnect   

toolbar button. 
2) Change the interface settings by selecting Interface Settings from the Options menu or press 

Settings   toolbar button. The Interface Settings option is enabled only when the application is not 
connected with ID7. 

3) After changing interface settings, select Connect from the File menu (or press Connect  toolbar 
button) to connect again to ID7. The interface settings have to correspond to those available on 
FormPacXP. 

 
• If connected properly, the application will read and verify certain data from ID7. If the connected ID7-

FormPac-XP unit is not licensed for using MT-FormTool, a warning message will be displayed. In this 
case, the transaction (dispensing) details are not tracked. Please contact Mettler Toledo Service for 
upgrade. 

 
• The application will continue to read the Terminal-Id from ID7 (stored in AB004) and makes an entry 

in the registry. 
 

If the terminal-id is empty (not assigned) in ID7, the application will provide an option to assign a unique 
terminal-id for the connected ID7 terminal. The Terminal-Id dialog box will appear. 
 

1) Enter the Terminal-Id (max of 20 characters) in the edit box. 
2) Press OK button. 

 

2. Connecting to ID7 
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The application will write the user-input terminal-id into ID7. If terminal-id is not entered, it will be taken as 
‘Unassigned’. The terminal-id is shown in the status bar. 

 
• After verifying the terminal-id, the application will open the corresponding database file. If the tool is 

connected with an ID7 terminal for the first time, database file name need to be provided. Enter a new 
file name or an existing file name. This file will be associated with the connected ID7 terminal. 

 
• If Inventory Control is enabled and Enable Store option is enabled, then a dialog box is shown with 

an option to assign the connected terminal with a store. For more details refer the title Inventory 
Control.  
 

• The ID7 display panel will show the current scale weight in ID7 with the scale unit and scale-id 
details. 
 

• MT-FormTool finds the current application set in ID7 and switches to the corresponding application. 
The current application name is shown in the window title. 

 
• If the current application is set to Stored Formulation, then MT-FormTool checks the stored 

formulation database Table-Ids (TIDs) set in ID7 and in MT-FormTool database file. If the table ids are 
not same, it means that the stored formulation database in ID7 and in PC are different. To 
synchronize the database and for more information, see Table-IDs section. 

 
For every connection, the session information is maintained in the database file. For more information 
about session details, see Session information section. 

 

 
MT-FormTool can track multiple FormPac-XP by instantiating multiple instances of the tool on the same 
PC. 

 
• MT-FormTool maintains the settings of each ID7 terminal separately based on the Terminal-Id in the 

system registry. For every ID7 terminal, the tool maintains the database file name and communication 
parameters separately with a unique terminal-id. 

 
• When MT-FormTool is connected to ID7, it reads the terminal-id from ID7 and gets the corresponding 

terminal details from the system registry and loads the corresponding database file. 
 
• If two or more terminals are available, the tool can be connected to an ID7-terminal by selecting the 

Terminal-Id option in the Interface Setting dialog box. 
 
• The same database file can be used to monitor more than one ID7 terminal. The dispensing details 

from all the ID7 terminals will be stored in a single file if the same database file is used for all the 
terminals. 

 
 
Note: 
If an ID7 terminal is connected with MT-FormTool through COMM port (or Ethernet), and if another 
instance of MT-FormTool is trying to connect with the same ID7 through Ethernet (or COMM port) from 
some other PC, then only the latest connected MT-FormTool instance will receive the state messages 
from ID7. The previously connected MT-FormTool instance (through COMM or Ethernet) won’t get any 
messages from ID7. 
 
Do not try to connect MT-FormTool with an ID7, which is already connected with another MT-FormTool 
instance.   
 

a. Multi-Instance feature 
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Table IDs (TIDs) are 16 bit signatures maintained to track the changes in Stored Formulation database. 
Three TIDs are maintained separately for Raw materials table, Formula table and Message table  
 
Whenever the stored formulation database is changed in MT-FormTool, it updates the TIDs for the 
corresponding tables. 
 
When MT-FormTool is connected with ID7, it verifies the TIDs with ID7. If the TIDs are different, a window 
with all TIDs details is shown. The TIDs of changed tables are shown with bold letters. Accept the 
message and press OK to continue. 
 
To synchronize the Stored Formulation database: 

1. Open DB configuration window by selecting DB Configuration  from the Tools menu. 
2. Select Read/Sync/Send option. 
 
When the synching operation is completed, TIDs are updated in ID7. 
 
Every time MT-FormTool is connected with ID7, it logs the session information in the database file. See 
Session Information for more details. 
 

 

 
To create a new file, follow the steps below. 
 

1. Select New from the File menu or press New  toolbar button.  New file dialog box appears.  
2. Enter a name for the new file 
3. Press Save button.  

 
A new database file is created and will be opened by the application. In the window title, the newly created 
file name is shown. 

b. Opening a file  
 
To open an existing database file, follow the steps below. 
 

1. Select Open from the File menu or press Open  toolbar button. Open File dialog box appears.  
2. Select the file. 
3. Press Open button.  
 

If the specified file is a valid database file, the application will open the file. If the file is not a valid file, then 
error message will be shown. The opened file name is shown in the window title. 
 
 
 

b. Table IDs (TIDs)

3. File Operations 

a. Creating a new file



FormToolXP – Operating Instructions 
 
 

Page 9 of 60 
FormToolXP_Operating Instructions_engl.doc                                                                                                                          

c. Saving a file  
 
This option saves the currently opened database file with a new name. 
To save the file, follow the steps below. 
 

1. Select Save As from the File menu or press Save As  toolbar button. Save As File dialog box 
appears. 

2. Enter a name for the new file. 
3. Press Save button. 
 
The current database file is saved with the new name. The newly created file serves as the current file.  

d. Export Database  
 
Exporting database will copy the Stored Formulation tables to the given database file from the currently 
opened file. Save As option copies the entire set of tables including Transaction records, where as 
Export will copy only Stored Formulation tables- RM Table, MSG Table and Formula Table. You can 
open the newly exported file as any other database file. 

 
The following procedure can be used to export database contents. 

 
1. Open the existing database file where the formula / raw material details have to be changed. 
2. Select Export from the File menu. 
3. Enter NEW file name and press Save button. The DB Configuration contents will be exported to this 

file. 
 
The Export option will be mainly used when the stored formulation database is changed. Please refer the 
topic Impact on modifying database for more details. 
 

e. Import Database 
 

Import database option will copy the Stored Formulation tables from the given database file to the 
currently opened file. For importing database, the corresponding tables in the current file should be empty. 
That is, a new set of Stored Formulation Tables cannot be imported into a Database file that has these 
tables established. The import operation is allowed only once – when a New Database File is opened 
(after File->New operation). 

 
The following procedure can be used to create a new file with exported database contents. 
 
1. Create a New Database File. 
2. Select Import from the File menu and Import the saved DB Configurations. That is, enter the file 

name whose DB configurations have to be copied to the currently opened file. 
3. The Stored Formulation tables will be imported from the existing database file to the new file. 
4. Now change the database contents in the new file and download (or sync) this file to ID7 and start 

using this file. 
 
The Import option will be mainly used when the stored formulation database is changed. Please refer the 
topic Impact on modifying database for more details. 
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MT-FormTool will monitor the dispensing details of all applications in FormPac-XP. 
The following applications are monitored by the MT-MT-FormTool. 
 
• Formulation 
• Pharma Formulation 
• Totalizing 
• Stored Formulation 
 

 
In Formulation, the containers and their individual component weights are monitored by the MT-FormTool. 
 
Each container is tracked by a serial number. For every container, the tool shows the recipe (formula) 
name, start date, start time and end time. 
 
The component details for the selected container are shown in the table view. The table view shows the 
component number (1-15), component name, dispensed weight, dispensed time and the scale id in which 
it is dispensed. 
 
For components dispensed using scale, the weight in the table view is shown in blue color. For manually 
dispensed components, the dispensed weight is shown in black color. 
 
In Formulation application, the main window will look like the figure below. 
 

 
 
 
 
 

4. Monitoring Applications

a. Formulation 
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The tool tracks the component name, dispensed weight, tare weight, dispensed date and time and scale 
id. All the components are shown one by one in the table view. 
 
For components dispensed using scale, the weight in the table view is shown in blue color. For manually 
dispensed components, the dispensed weight is shown in black color. 
 
In Pharma Formulation application, the main window will look like the following figure. 
 

 
 

 
The tool tracks the component name, dispensed weight, dispensed date and time and scale id. 
 
For components dispensed using scale, the weight in the table view is shown in blue color. For manually 
dispensed components, the dispensed weight is shown in black color. 
 
In totalizing application, the main window will look like the following figure. 
 

b. Pharma Formulation 

c. Totalizing 
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Whenever a formula is selected and dispensed in ID7, the MT-FormTool application will read and store 
the details of the formula selected and its compounds.  When multi-charge option is enabled (Kitting) in 
ID7, the application will log every split-dispensed detail. 
 
Formula Details 
When a formula is selected for dispensing in ID7, MT-FormTool will read the details of the selected 
Formula and all of its compounds. In the main window, the formula details are shown below the ID7-Panel 
(Weight Display). The compound details are shown in a table. 
 
When a formula is selected, the tool will read and display formula name, formula id, lot number, 
dispensing start date, start time and end time. And formula target weight, actual weight and tare weight 
are also shown below the table view. 
 
Compound Details 
When a compound is selected for dispensing, the corresponding compound in the table view is highlighted 
by means of blinking the item with a green color. The compound is blinked until the compound is either 
dispensed or cancelled. 
 
When the compound is selected, the table view shows the compound name, target weight, tolerance 
weight and start time of dispensing. Once the compound is dispensed its dispensed weight, dispensed 
tolerance (Delta) and scale-id are updated in the table view. During dispensing the status bar displays the 
current state of the compound (e.g. selected, dispensed or cancelled). 
 
Multi-charge (Kitting) 
If the multi-charge option is enabled, the individual split dispensing details (Dispensed Wt, Charge No) 
will be shown in the table view for every compound.  
 
The compounds details can be viewed in two ways namely Expand and Shrink mode. Any one of these 
options can be selected by right clicking the mouse on the table view and selecting the appropriate option 
in the pop-up menu.  
 

d. Stored Formulation 
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The Shrink menu option will show only the compound name, target, tolerance, and dispensed weights. 
The Expand menu option will show all the split-weights, all charge numbers, scale id and start time (and 
hides columns that has no data). 
 
Scale Id 
If the compound is dispensed using scale (not manually), the corresponding scale id is shown in the last 
column of the table view. If the compound is dispensed manually, the scale-id is not shown. 
 
Batch Mode 
If a formula is dispensed in BATCH mode, the tool displays individual batch weights (for each compound) 
along with compound name, target and tolerance weights. The columns with labels Disp wt_1, Disp Wt_2, 
... Disp Wt_N shows the batch weights, where N is total number of batches. 
 
The charge number for each compound is shown in the last column of the table view. The formula target 
weight, total number of batches and the current batch id are displayed below the table view. While 
dispensing, the current batch id is updated with the selected batch. The status bar will display the current 
iteration number and compound number when the compound is selected for dispensing. The current batch 
id is shown only during dispensing. 
 
Parking 
If the formula is parked during dispensing, the application stops logging and the formula status is updated 
as Parked. The formula status is shown just below the ID7 display panel. When the parked formula is 
loaded, the application will load the corresponding formula that is already stored in the database file.  
 
Formula Status 
The formula status describes the dispensing status of the formula. The following are the different formula 
status with description. 
 
‘Dispensed’  - The formula was dispensed 
‘Parked’ - The formula was parked 
‘Cancelled’ - The formula was cancelled 
‘Dispensing’ - The formula is being dispensed 
‘Interrupted’ - Dispensing was interrupted by the user 
 (If the user disconnects or closes the MT-FormTool application while dispensing a formula, the status is 
updated as ‘Interrupted’) 
 
Color-coding 
For manually dispensed compounds, the dispensed weight is shown in black color. Otherwise the 
dispensed weight is shown in blue color. 
 
If the delta value is negative, it is shown in red color. It is shown in light gray color if it is a positive value. 
If the delta is exactly zero, then it is shown in green color. 
 
Note: 
For BATCH dispensing, there is no color-coding. In batch mode, all the values are shown in blue color. 
 
Terminal-Id 
The terminal-id displayed in edit box shows from which ID7 terminal the current formula was dispensed. 
 
The terminal-id in the status bar shows the terminal-id of the connected ID7 terminal. The terminal-id 
shown in the edit box (above the table view) shows the terminal-id in which the currently loaded formula is 
dispensed. 
 
Screen samples 
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Stored formulation – Vertical/Horizontal Mode 
 
 

 
 
Stored formulation – Batch Mode 

 
Charts / Graphs 
 
Compound weights can be visualised graphically during monitoring. Three types of graphs are provided, 
namely Pie, Histogram and Progress Bar. The required chart can be selected by right-cliking the mouse 
on the chart and selecting the graph option from the pop-up menu. 
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Different colours are used in a chart to identify dispensed compounds. Compounds that are not dispensed 
are shown in WHITE (default) colour. 
 
Pie chart and Histogram supports upto 20 compounds. If more than 20 compounds exist in a formula, then 
they are represented via Progress Bar. 
 

 
There are four applications in FormPac-XP. Once the tool is connected with ID7, the tool will read the 
current application in ID7 and switches to that application.  
 
Once connected, the tool cannot switch to other applications. To view the contents of other applications, 
first disconnect from ID7 and then choose any one of the applications from the Application menu. The 
tool will switch to the selected application and the entire window contents will show the details of the 
selected application (The current application is shown with a tick symbol in the Application menu). The 
current application is also shown in the window title. 
 
Note: 
The option DB Configuration in the Tools menu is enabled only when the current application is set to 
Stored Formulation. 
 

To view or design formula database, select DB Configuration from the Tools menu or select  toolbar 
button. DB Configuration window will appear. The RM, Formula and Message toolbar items are used to 
edit Raw Materials, Formulae and Message databases correspondingly. By default Raw Materials table is 
shown. 
 
Note: 
The DB Configuration option in the Tools menu is enabled only when the current application is set to 
Stored Formulation. 
 

 
Click the toolbar item named RM in DB Configuration window. The RM table is shown with 500 raw 
materials. 
 
To edit a RM, follow the steps below. 
 
1) Select the raw material (row in the table) to edit. 
2) Press Edit button (or Right click the mouse on index (first) column and select Edit from the pop-up 

menu). 
3) Enter the RM id (unique), Description, Message ID, Stock, Warning level. Consumed, Stock Date, 

Stock Time and Used Count are not editable. 
4) Press Save button (or right-click on the index column and select Save from the pop-up menu). Or 

press Cancel button (or select Cancel from the pop-up menu) to cancel the updates. 
 
Note: 
If the raw material is already created, raw material id cannot be changed. To change the raw material id, 
delete the raw material and create it again. 
 
 

e. Switching between applications

5. Stored Formulation Database

a. Designing Raw Materials 
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RM table constraints: 
 
1) RM Id can be of up to a maximum of 20 characters. It must be unique. 
2) RM Name can be of up to a maximum of 30 characters. 
 
To delete a raw material, follow the steps below. 
 
1) Select the raw material to delete. 
2) Press Delete button (or right click the mouse on index (first) column and select Delete from the pop-

up menu). 
3) Press OK button to delete the raw material or Cancel button to cancel the deletion. 

 
Note: 
Raw material can be deleted only if its used count is 0. For empty records, the used count will be empty. 
 
Please refer Impact on modifying database topic when changing database.  
 
The RM table will look like the following figure. 
 

 
 

 
Click the toolbar item named Formula in the DB Configuration window. The formula tables are shown. 
There are two tables in the formula. The upper table called Formula Table shows the formula details and 
the lower table called Compounds Table shows formula compounds details for the selected formula. 
There are 150 formulae in the formula table. 
 
To edit a formula in formula table, follow the steps below. 
 
1. Select the formula to be edited in the formula table. 
2. Press Edit button (or right click the mouse on index (first) column and select Edit from the pop-up 

menu). 
3. Enter the Formula ID, Formula name, three Pre-Messages and two Post-Messages. 

b. Designing Formulae 



FormToolXP – Operating Instructions 
 
 

Page 17 of 60 
FormToolXP_Operating Instructions_engl.doc                                                                                                                          

4. Press Save button (or right-click on the index column and select Save from the pop-up menu). Or 
press Cancel button (or select Cancel from the pop-up menu) to cancel the updates. 

 
Note: 
If the formula is already created, formula id cannot be changed. To change the formula id, delete the 
corresponding formula and create again. 
 
Formula table constraints: 
 

• Formula Id can be up to maximum of 10 characters.  
• Formula Id must be unique. 
• Formula Name can be up to maximum of 30 characters. 

 
To delete a formula in formula table, follow the steps below. 
 
1. Select the formula to be deleted in the formula table. 
2. Press Delete button found below the formula table (or right click the mouse on index (first) column in 

formula table and select Delete from the pop-up menu). A warning message will be displayed 
3. Press OK button to delete the formula or Cancel button to cancel the deletion. 
 
Note: 
Deleting a formula deletes the formula and all of its compounds. 
 
To add a compound, follow the steps below. 
 
1. Select the formula to be edited in formula table. The corresponding compounds will be shown in the 

compounds table. 
2. Select an item in the compound (lower) table. 
3. Press Edit button found below the compounds table (or right click the mouse on index (first) column 

and select Edit from the pop-up menu). 
4. Select the Raw Material ID from the (RM ID column) list. The corresponding raw material name will be 

shown in the next (RM Name) column. 
5. Enter target weight, tolerance weight, pre-message and post-message. 
6. Press Save button found below compounds table (or right click the mouse on index (first) column in 

compound table and select Save from the pop-up). Or press Cancel button (or select Cancel from the 
pop-up menu) to cancel the updates. 
 

To add more compounds follow the steps above. The same compound can be added more than once in a 
formula. 
 
Constraints: 
 
• A maximum of 100 compounds can be added for a formula. 
• Tolerance weight must be less than or equal to half of the target weight. Otherwise it can have a value 

up to 50%. 
 
To edit/change a compound, follow the steps below. 
 
1. Select the formula to be edited in formula table. The corresponding compounds will be shown in the 

compounds table. 
2. Select an item in the compound (lower) table. 
3. Press Edit button found below compounds table (or right click the mouse on index (first) column and 

select Edit from the pop-up menu). 
4. Change the compound details. 
5. After changing the compound values press Save button (or right click the mouse on index (first) 

column and select Save from the pop-up). Or press Cancel button (or select Cancel from the pop-up 
menu) to cancel the updates. 
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To delete a compound, follow the steps below. 
 
1. Select the formula to be edited in formula table. The corresponding compounds will be shown in the 

compounds table. 
2. Select an item in the compound (lower) table. 
3. Press Delete button (or right click the mouse on index (first) column and select Delete from the pop-

up menu). A warning message will be displayed. 
4. Press OK button to delete the compound or Cancel button to cancel the deletion. 

 
The formula table will look like the following figure. 
 

 
 
 
Please refer Impact on modifying database topic when changing database.  
 

 
Click the toolbar item named Message in DB Configuration window. There are 200 items in the message 
table. First 30 messages are read-only messages and they cannot be modified. 
 
To edit a message, follow the steps below. 
 
1) Select an item (row in the table) to edit. 
2) Press Edit button (or right click the mouse on index (first) column and select Edit from the pop-up 

menu). 
3) Enter the Message text. 
4) Press Save button (or right-click on the index column and select Save) to save the changes. Or press 

Cancel button (or select Cancel from the pop-up menu) to cancel the updates. 
 
 
 
 
 

c. Designing Messages 
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Note: 
 

• Messages 1 to 30 are fixed messages and cannot be edited. 
• Message text can be up to a maximum of 24 characters. 
 

To delete a message, follow the steps below. 
 

• Select an item (row in the table) to edit. 
• Press Delete button (or right click the mouse on index (first) column and select Delete from the 

pop-up menu). A warning message will be displayed. 
• Press OK button to delete the message or press Cancel button to cancel the deletion. 

 
The message table will look like the following figure. 
 

 
 
Please refer Impact on modifying database topic when changing database. 
 

 
The entire database (includes Raw materials, formulae and messages) can be downloaded to ID7 by 
clicking the Send toolbar item. Before downloading, the application will delete all the raw materials, 
formulae and messages in ID7 and then it will start writing messages, raw materials and formulae to ID7. 
A warning message will be shown before updating the data in ID7. 
 

 
1. To read the database from ID7, press the Read toolbar item in the DB Configuration window. A dialog 

box with the reading options will be shown. 
2. To read all tables (i.e., Raw materials, Formulae and Messages), select ReadAll option.  
3. To read individual tables, choose Read option and select any of the tables. 
4. Press OK button to start reading. Now the selected tables in the local database file will be cleared to 

hold the new data. 

d. Sending Database to ID7

e. Reading Database form ID7
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5. A warning message is shown regarding this action. Press Yes button to clear the selected tables and 
start reading the selected tables from ID7. 

 

 
The Sync option is used to synchronize your database with the ID7. This will update the database in ID7 
with the database in MT-FormTool. Once the entire database is read from ID7, database need not be 
downloaded every time when small changes were made. 
 
If the entire database is read from ID7, and if any changes were made (adding, editing or deleting some 
records), only the changed records will be updated in ID7 by Synchronization. This can be invoked by 
pressing Sync toolbar item. Sync saves the time. 
  
When this option is used, the application assumes that the user has already read the entire database 
recently. 
 
If the database in ID7 is changed by some other means (i.e., without using MT-FormTool), then the sync 
option may not work properly. In these cases, the entire database should be read again to use sync. 
 

 
Every time MT-FormTool is connected with ID7, current session information is stored in the database file. 
 
To view session information, 
 
1) Open DB Configuration window by selecting DB Configuration ({bmc DBConfig.bmp}) from the 

Tools menu. 
2) Select DB info toolbar button. 
 
Session information window appears. In this window, current database file name, file size, three TIDs are 
shown. All the session information taken for every connection is displayed in the list view.  
 
The list view contains the following details. 
 
1) Serial no. 
2) Terminal ID. 
3) User Name 
4) Date and Time at which the connection established. 
5) Record No (no of formulae dispensed when connection is established). 
6) Message TID, RM TID and Formula TID at the time of connection. 
7) Session Status showing whether the database is synchronized or not. 
 
Clearing Logged Info: 
The logged session information can be cleared by selecting Clear Logged Info from the Tools menu. 
This option will also delete the user logging information file logfile.txt stored in the MT-FormTool 
installation directory. 
 
 
 
 
 
 

f. Synchronizing Database with ID7

g. Session Information 
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a. Reports – Introduction  
 
Report Wizard provides a range of reports based on the data collected by MT-FormTool. The Wizard is 
used to generate graphical and text reports, based on the dispensed details for all the four applications of 
FormPac-XP.  
 
The Wizard provides different types of analysis as follows: 
 
Stored Formulation: 
 
• Trend analysis 
• Error analysis 
• Consumption analysis  
• Production analysis  
 
Formulation: 
Recipe and Component analysis 
 
Pharma-Formulation & Totalizing: 
Components analysis 
 
The data can be displayed graphically in several modes namely Tables, Histograms, Pie Charts or Plots. 
 
The Advanced Reports section can be used to generate customized reports. Using Advanced Reports, 
user can design a query based on database fields to produce required reports for all the FormPac-XP 
applications. For more details, see Advanced Reports section. 
 
The Reports Application provides the following features: 
 
• Print the generated report 
• Customize styles (namely Fonts, Colors and Tags) 
• Customize Header and Footer (allows to configure 1 line for header and 2 lines for footer) 
• Save the generated report for future reference (saves as HTML file or Excel file). 
 

 
• To invoke the report generation wizard, choose Reports from the Tools menu (or press Reports 

toolbar button) in the MT-FormTool main window. 
• The report generation tool appears with the option to choose the database file. By default, the current 

file that is opened by the MT-FormTool will be shown. Select this file or browse for an existing one and 
press OK button to continue. 

• The Report Generation Wizard appears. The first page of the wizard is shown in the following figure. 
• In the first page of the wizard, select the type of application. Choose any one of the following four 

applications in the wizard. 
 

1) Stored Formulation 
2) Formulation 
3) Pharma Formulation 
4) Totalizing 

 

6. Report Generation

b. Starting Wizard
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• Select the ID7 Terminal-Ids to which the reports have to be produced. See Visualizing Multiple ID7 
Terminal Reports for more details. 

• The reports can be generated based on the user name. Select the user names. See Visualizing 
Reports for Multiple Users for more details. 

 
Note: 

To invoke wizard manually, select Wizard from the Tools menu or press wizard  toolbar button. 
 
Back option 
 
Once the report is generated and if any minor change has to be done in the current report, it can be easily 
done by using Back toolbar button. This option enables the user to go back to the previous interface from 
which the active report was generated.  To make any change in the current report, follow the steps below. 
 

1. Press the Back toolbar button in the reports window. The previous wizard/advanced reports 
window will appear. 

2. Make the necessary changes and generate report again.   
 
Pressing Back toolbar button will clear the current report and go back to the previous Wizard screen or 
Advanced reports window which ever is appropriate. This can also be done by choosing the menu option 
Back from the View menu. 
 
Wizard screen is shown below. 
 

 
 

 
The following graph options are available in the wizard. 
 
Show batch results separately: 
If this option is selected batch mode dispensing are shown separately. 
This option is available only for “Trend Analysis” and “Error Analysis”. 
 
Show Grid: 
If this option is enabled in Histogram or Plot graph, the report is shown in grid fashion. 
In text report if this option is enabled, the report is shown with rows and columns spanning the entire 
report. 

c. Graph Options
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Apart from the standard reports produced by the MT-FormTool's Reports Wizard, user can also generate 
customized reports using "Advanced Reports" feature. 
 
Using Advanced Reports, user can design queries based on database fields to produce required reports 
for all the FormPac-XP applications. 
 
In Stored Formulation, in addition to the dispensed details, the original Formula/Raw material/Message 
database details can also be analyzed. For example, listing all the formulae that use a specific Raw 
Material. 
 
The major features of Advanced Reports are highlighted below: 

 
• Constraints (conditions) can be used in queries to retrieve filtered data. 
• During query designing, all the fields and their constraints (conditions) will be available in individual 

columns that can be selected by the user as required. 
• The designed query can be saved and retrieved for future use. Any number of such queries can be 

designed and saved. 
 
Back option 
 
Once the report is generated and if any minor change has to be done in the current report, it can be easily 
done by using Back toolbar button. This option enables the user to go back to the previous interface from 
which the active report was generated.  To make any change in the current report, follow the steps below. 
 

1. Press the Back toolbar button in the reports window. The previous wizard/advanced reports 
window will appear. 

2. Make the necessary changes and generate report again.   
 
Pressing Back toolbar button will clear the current report and go back to the previous Wizard screen or 
Advanced reports window which ever is appropriate. This can also be done by choosing the menu option 
Back from the View menu. 
 

 
Reports are generated for a database file. Before generating a report, a valid database file must be 
opened for which the reports shall be generated. By default, the wizard takes the currently running 
database to generate reports. 
Otherwise any other database can be made open by selecting Open option from File menu or by pressing 

Open  toolbar button. 
 

 
Multiple Terminal-IDs: 
 
MT-FormTool monitors multiple ID7 terminals and the data from all the ID7 terminals can be logged on to 
a single database file. Reports can be generated for more than one Id7 terminals.  
 
Select the required terminals from Terminal-ID option list in the wizard’s first page. 

d. Advanced Reports 

e. Opening a Database file for Reports

f. Visualizing Multiple ID7 Terminal Reports
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If multiple Terminal-IDs are selected, reports can be used to produce consolidated results or the same 
report can be used for displaying each Id7 terminal results in a distinct fashion. In such a case, a 
maximum of three ID7 terminals are shown in the produced report. 
 
The option Terminal-ID in Show by section is allowed only in Error, Consumption and Production 
analysis of Stored Formulation application. This option is allowed for a maximum of 3 Terminal-IDs. 
 
If this option (Terminal-ID) is selected, the resultant report will be shown as follows: 
 
Histogram Representation : Shown as a 3D chart. 
Plot Representation  : Individual plots are used to represent each Terminal-Id. 
 
Otherwise, the report is shown as follows: 
 
Histogram Representation : Shown as a 2D chart. 
Plot Representation  : Single line graph is shown. 
 
Note: 
Irrespective of multiple Terminal-IDs option, if the number of samples exceeds 15, then 3D charts cannot 
be accommodated. In this case, a 2D chart is displayed. 
 
Wizard screen is shown below. 
 

 
 

 
Multiple User Names: 
 
MT-FormTool tracks the user name during dispensing. Reports can be generated for more than one user 
name. Required user names can be selected from the User name option list in the wizard’s first page. 
 
If multiple user names are selected, reports can be used to produce consolidated results or the same 
report can be used for displaying results for each user. In such a case, a maximum of three user names 
are shown in the produced report. 

g. Visualizing Reports for Multiple Users
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The option User name in Show by section is allowed only in Error, Consumption and Production analysis 
of Stored Formulation application. This option is allowed for a maximum of 3 user names. 
 
If this option is selected, the resultant report will be shown as follows: 
 
Histogram Representation : Shown as a 3D chart. 
Plot Representation  : Individual plots are used to represent each Terminal-Id. 
 
Otherwise, they are shown as follows: 
 
Histogram Representation : Shown as a 2D chart. 
Plot Representation  : Single line graph is shown. 
 
Note: 
Irrespective of multiple user name option, if the number of samples exceeds 15, then 3D charts cannot be 
accommodated. In this case, a 2D chart is displayed. 
 
Wizard screen is shown below. 
 

 
 
 

 
In Stored Formulation, reports can be used to view “Dispensing details of Formula / Raw Materials”, “Error 
in dispensing of Formula / Raw Materials”, “Usage of Raw Materials” and “Production of formulae”. 
 
The report types are categorized as follows: 
 
1) Trend Analysis 
2) Error Analysis 
3) Consumption Analysis 
4) Production Analysis 
 
Select any item to view details. 
 
Trend analysis 
 

h. Stored Formulation Reports 
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Trend Analysis is used to analyze the target and dispensed weights of a formula or a compound (raw 
material) in a formula. To generate Trend Analysis report, follow the sequence of steps given below. 
 
• In the FormTool Report Wizard screen, select the option Trend Analysis. 
• In Based On section, select the option Formula or Raw Material. 
• Select the required terminal-ids and user names from the Terminal-ID list and User name list 

respectively. 
• In trend analysis, either Histogram/Text report can be produced. Select the desired chart in the 

Chart/Report section. 
• Press the Next button. Second page of the wizard appears. 
• If the analysis is selected based on formula, then a list of formula Ids is shown in the Formula ID 

drop-down list. Select a formula id from the list. The corresponding formula name is shown nearby. 
• If the analysis is based on raw material, then a list of raw materials is shown in the Raw Material Id 

drop-down list. Select a raw material id from the list. The list of formulae that use this raw material will 
be listed below in the Formula Id drop-down list. Select any one formula id from the list. (A formula 
can use a raw material more than once. In this case, a list of duplicated compounds will be displayed, 
which can be selected). 

• Select the further options Date range and Graph Options. 
• After selecting the report options, press Finish button to generate the report. 
The generated trend analysis report is shown. 

 
Error analysis 
 
The dispensed value of a raw material or formula may deviate from their target weights. In Error 
Analysis, the percentage of error during dispensing of each raw material or a complete formula can be 
analyzed. The graph shows the error values of eachdispense operation. The total deviation of the 
samples is shown at the bottom of the graph. 
 
To generate Error Analysis reports, follow the procedure given below. 

 
• In the FormTool Report Wizard screen, select the option Error Analysis. 
• In the Based On section, select the option Formula or Raw Material. 
• Select the required terminal-ids and user names from the Terminal-ID list and User name list 

respectively. 
• In Error Analysis, either Plot/Text report can be produced. Select the desired chart in the 

Chart/Report section. 
• Press the Next button. Second page of the wizard appears. 
• If the analysis is selected based on formula, then a list of formula Ids is shown in the Formula ID 

drop-down list. Select a formula id from the list. The corresponding formula name is shown nearby. 
• If the analysis is based on raw material, then a list of raw materials is shown in the Raw Material Id 

drop-down list. Select a raw material id from the list. The list of formulae that use this raw material will 
be listed below in the Formula Id drop-down list. Select any one formula id from the list. (A formula 
can use a raw material more than once. In this case, a list of duplicated compounds will be displayed, 
which can be selected). 

• Select the further options Date range and Graph Options. 
• After selecting the report options, press the Finish button to generate the report. 
The generated error analysis report is shown. 
 
 
Consumption analysis 
 
In consumption analysis, usage of raw materials is analyzed. This analysis focuses on stock 
management.  
The following four reports can be generated in consumption analysis.  
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1) Total consumption 
2) Date-wise report 
3) Highly consumed 
4) Least consumed 
 
To generate the report, the procedure listed below can be followed. 
 
• In the FormTool Report Wizard screen, select the option Consumption Analysis. 
• Select the required terminal-ids and user names from the Terminal-ID list and User name list 

respectively. 
• In Consumption Analysis, Histogram, Pie Chart or Text report can be produced. Select the desired 

chart in the Chart/Report section. 
• Press the Next button. Second page of the wizard appears. 
• Now, select the required report type listed below. 
 
Total usage of raw materials: (Total consumption) 
 
This report shows the usage of selected raw materials. To view this report, select the required raw 
materials from the list provided in Choose Raw Materials section. 
 
Date-wise report for a raw material: (Date-wise report) 
 
This report shows the usage of a raw material in the given date range. To view this report, select the 
required raw material from the list provided in Choose Raw Materials section.  
 
Most used raw materials: (Highly consumed) 
 
This report analyses highly used raw materials. The section Top can be used to specify the top N highly 
used raw materials. 
 
Least used raw materials: (Least consumed) 
 
This report analyses least used raw materials. The section Top can be used to specify the top N least 
used raw materials. 
 
• Select the further options Date range and Graph Options. 
• After selecting the report options, press the Finish button to generate the report. 
The generated consumption analysis report is shown. 
 
Production analysis 
 
In production analysis, the production of formulae is analyzed. This analysis focuses on production 
management. 
 
The following five reports can be generated in production analysis. 
 
1) Total production of formulae 
2) Dispensed, Cancelled and Parked count of each formula 
3) Date-wise report for a formula 
4) Highly consumed 
5) Least consumed 
 
To generate the report, follow the procedure listed below. 
 
• In the FormTool Report Wizard screen, select the option Production Analysis. 
• Select the required terminal-ids and user names from the Terminal-ID list and User name list 

respectively. 



FormToolXP – Operating Instructions 
 
 

Page 28 of 60 
FormToolXP_Operating Instructions_engl.doc                                                                                                                          

• In Production Analysis, Histogram, Pie Chart or Text report can be produced. Select the desired 
chart in the Chart/Report section. 

• Press the Next button. Second page of the wizard appears. 
• Now, select the required report type listed below. 

 
Total production of formulae: 
 
This report shows the production of selected formulae. To view this report, required formulae can be 
selected from the list provided in Choose formulae section. 
 
Dispensed, Cancelled and Parked count of each formula: 
 
This report shows the dispensed, cancelled and parked count of the selected formula. To view this report, 
select the required formula from the list provided in Choose formula section. 
 
Date-wise report for a formula: 
 
This report shows the production of a formula in the given date range. To view this report, select the 
required formula from the list provided in Choose formula section. 
 
Highest volume produced: (Highly consumed) 
 
This report analyses highly produced formulae. The section Top can be used to specify the top N highly 
produced formulae. 
 
Least volume produced: (Least consumed) 
 
This report analyses least used produced formulae. The section Top can be used to specify the top N 
least produced formulae. 
 
• Select the further options Date range and Graph Options. 
• After selecting the report options, press the Finish button to generate the report. 
The generated production analysis report is shown. 
 

 
In Formulation, reports can be used to view weight details of Recipe / Components. 
 
To generate the report, follow the procedure listed below. 
 
• In the FormTool Report Wizard screen, select the option Formulation. 
• In Based On section, select the option Recipe or Components. 
• In Formulation analysis, Histogram, Pie chart or Text report can be generated. Select the desired 

chart in the Chart/Report section. 
• Press the Next button. Second page of the wizard appears. 
• If the analysis is based on recipe, the recipe range has to be selected. Specify the start and end 

range for the recipe. The selected recipe names between the given ranges are shown in the selected 
name(s) list for reference. 

• If the analysis is based on components, select a recipe number. The corresponding recipe name is 
shown nearby. All the components of the selected recipe will be shown in the report. 

• Select the further options Date range and Graph Options.  
• After selecting the report options, press the Finish button to generate the report. 
The generated Formulation analysis report is shown. 
 

i. Formulation Reports 
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In Formulation, reports can be used to view weight details of Components. The steps to generate report 
for Totalizing and Pharma Formulation are exactly the same. 
 
To generate the report, the procedure listed below can be followed. 

 
• In the FormTool Report Wizard screen, select the option Pharma Formulation/Totalizing. 
• In Totalizing / Pharma Formulation analysis, Histogram, Pie chart or Text report can be generated. 

Select the desired chart in the Chart/Report section. 
• Press the Next button. Second page of the wizard appears. 
• Components can be selected using the index. Specify the start and end range for components. The 

selected component names between the given ranges are shown in the Selected name(s) list for 
reference. 

• Select the further options Date range and Graph Options.. 
• After selecting the report options, press the Finish button to generate the report. 
The generated report is shown. 
 

 
Queries can be designed manually and saved for future use. 
 
To design a query, follow the steps below. 

• Select Advanced Reports from the View menu or press  toolbar button. Advanced Reports 
screen will appear. 

• If Advanced Reports screen is invoked for the first time (i.e. if no queries are created previously), a 

New Query dialog box will appear. Otherwise select New Query  button. 
• In the New Query dialog box, select the query type from Report type drop-down (combo box) list. All 

query types are described below. 
• Enter the name for the new query. 
• Enter the description for the query (optional) and press OK button. Query description can be up to a 

maximum of 250 characters. 
 
A new empty query will be created with the given name. 
 
Depending on the report type selected, the field names listed in Advanced Reports screen will vary. In 
the Advanced Reports screen, individual columns are shown with database fields and its 
attributes/constraints (conditions). From these columns, the required fields and their constraints 
(conditions) can be selected to form a query. See title named Query Design for more details about 
designing a query. 
 
Report type options and their descriptions are listed below: 

1. Stored Formulation: Standard: 
If this report type is chosen, reports for all the dispensed details in Vertical and Horizontal filling 
modes can be produced. 

2. Stored Formulation: Batch Dispensing 
Reports for batch-dispensed details can be analyzed in this report type. 

3. Stored Formulation: Formula Details 
This report type can be used to produce reports on original Formula details in Formula database. 

4. Stored Formulation: Raw Material Details 
This report type can be used to analyze Raw Material details in Raw Material database. 

j. Totalizing / Pharma Formulation Reports

k. Individual queries with Advanced Reports 
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5. Stored Formulation: Messages 
This report type can be used to produce reports analyzing Messages database. 

6. Formulation 
This report type can be used to produce the dispensed details of Formulation application. 

7. Pharma Formulation 
This report type can be used to produce the dispensed details of Pharma-Formulation application. 

8. Totalizing 
This report type can be used to produce the dispensed details of Totalizing application. 

 
New Query dialog box is shown below. 
 

 
 
 
Query Design 
 
 
In the Advanced Reports screen, each row can have a database field. The columns corresponding to a 
row represents the attributes and constraints (conditions) of that field. 
 
From these columns, the required attributes and constraints (conditions) can be selected. In the 
Advanced Reports screen, clicking the left mouse button on each cell, allows to select the field 
items/values. 
 
Field Selection: 
In the Advanced Reports screen, the column with title Field contains a list of field names displayed in a 
tree structure.  
 
Choose any field name in the tree structure and specify the required constraints (conditions).  
 
Options 'Show', ‘Column name’ and 'Sort': 
 
Option Show is used to enable or disable printing the corresponding field in the report. If this option is set 
ON, then the field is printed in report.  (By default, all fields have the Show option set ON). 
 
Option Column name is used for customizable printout of the field name.  User can edit the field name as 
required. This name is used for printing. This text is editable only if Show option is set ON. 
 
Option Sort is used to specify the order of arranging data in printout, whether in ascending or 
descending order. A maximum of two levels of ordering is allowed namely, Primary and Secondary. 
 
Both levels can be used in a query. In such cases, the data are first ordered by the 'Primary' sort field and 
then by 'Secondary'. 
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Constraints: 
Constraints (conditions) are used to filter the data. 
 
When designing a query, data can be retrieved based on the user requirement, like retrieving all data 
matching a particular condition. 
 
In a query one or more constraints can be used. The column Operators holds a list of relational operators  
(=, <>, <=, >=, <, >, *). Please refer section Operators for more details on field dependent details on 
operators. 
 
An operator is used to relate (compare) the field value and the constraint. 
 
Once an operator is selected from column Operators, the column Constraint1 is enabled. Then the 
required constraint can be selected in that field. If the operator is not selected, no constraints can be 
added. 
 
Adding more Constraints: 
Multiple constraints can be used in a query. For example, two conditions like "target > 1 kg AND target < 5 
kg" can be specified in a single query. By default two constraints were added. 
 
To add more constraints in a query, right click the mouse on the index column in Advanced Reports 
screen and select Add Constraint from the pop-up menu. 
 
The column Condition holds a list of connectors (AND, OR). Please refer section Condition for more 
details. 
 
Deleting Constraints: 
To delete a constraint, right click the mouse on the index column in Advanced Reports screen and select 
Delete Constraints from the pop-up menu. All the added constraints (numbered from 3 to 10) will be 
shown in another pop-up menu. Select any constraint to delete. The first two constraints cannot be 
deleted. 
 
'Operators': 
Operators are used to relate/compare a field value with a given value.  The column Operators holds a list 
of relational operators, depending on the type of active field. The following table lists field-type dependent 
operators. 
 

Field Type Operators 
Text   =, <>, * 
Others  =, <>, <=, >=, <, > 

 
'Condition': 
Conditions are used to add multiple constraints. The column Condition holds two logical operators 
namely AND and OR. These conditions can be used to add more constraints to the query. 
 
If multiple constraints are used in a query, then, the order of executing the query will be on priority basis. 
Two constraints connected by the AND operator is given more preference. 
 
Running the Query 

Finally after selecting the fields, the created query can be executed by clicking Run button in the 
Advanced Reports screen. Before running the query, save the query. See title Saving a Query for more 
details. 
 
The generated report for the designed query is displayed. 
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Advanced Reports window is shown below. 
 

 
 
 
In Advanced Reports queries can be designed. Three examples for queries will be discussed on the 
following pages of this document. 
 
 
Saving a Query 
 

Once the query is designed it can be saved for future reference. By clicking the Save  button in the 
Advanced Reports screen, the query is saved. 
 
Option 'Save As': 
 
Option Save As is used to save the query with a different name.  
 

• Press Save As  button.  
• Enter the new query name and description and press OK button.  
The query will be saved with the new name. 
 
 
 
Deleting a Query 
 
If any saved query is not needed, it can be deleted. 

By clicking Delete button in the Advanced Reports screen, the selected query will be deleted. 
 
 
Clearing current query 

Active query shown in the Advanced Reports screen can be cleared by clicking the Clear  button. 
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Customize Option 
 
By default, all the fields related to the selected report type will be shown in the Advanced Report 
screen. User can eliminate some of these fields. In this case, the fields that are skipped by the user will 
not be available in the list of fields shown in Field column in Advanced Reports screen. 
 

The option Customize View in Settings menu can be used to customize the tables. The Customize  
toolbar button can also be used to customize the tables. This option will display the list of tables and their 
corresponding fields. In this screen, fields can be selected or deselected for the active report type. The 
primary key fields in tables cannot be deselected. 

Select the report type from Report type drop-down (combo box) list. The corresponding tables will be 

displayed with their filed names. Select or deselect the fields. Then pressing the  button saves the 

settings and closes the window. To exit without saving the settings press  button. 

The button  selects all the fields in the currently opened tables. 

The button  clears (deselects) all the fields (except primary key fields). 

 

Customize dialog box is shown below. 

 
 
 
Report Display/Printing 
 
By default, all the selected fields will be displayed in the report. If some fields have the Show option set to 
OFF, then those fields will not be displayed. 
 
By default, the constraint applied to fields will not be shown in the report.  If the option Show Constraints 
in Report Generator screen is enabled, then only those fields that are having constraint(s) will be shown. 
 
The report display screen size will be adjusted according to the size of the report. 
 
Once the report is displayed, it can be printed. Before printing, the report can be pre-viewed by selecting 
Print Preview option in File menu. 
 
Depending on Paper Size set in the Print Setup option in File menu, the report is printed in one or more 
pages. 
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Sample Queries 
 
In Advanced Reports queries can be designed. Three sample queries are described below. 
 
Sample 1 

 
Query: Select all the compounds with a specified formula name 
 
Steps: 

 
• Open the database file by selecting Open from File menu. As soon as the file is opened, the 

Reports Wizard appears. 
• Invoke the Advanced Reports window by clicking Advanced Reports button in the Wizard. 

Advanced Reports window will appear. 

• Click the New  toolbar button. A New Query popup window will appear. 
• In Reports Type drop-down list, select the Stored Formulation - Formula DB. 
• Enter a name in the name edit box and its description.  
• Click Ok button to save the query. Refer Fig 1. 
• In the Field column of Advanced Reports window, select Formula Name, Raw_Material_Name, 

Raw_Material_ID, Target _Weight of Compound and Tolerance of Compound all in separate 
rows. Refer Fig 2. 

• In Formula Name row select the '=' operator in operator column and in constraint1 column select 
the desired Formula Name. Refer Fig 3. 

• Click the Run toolbar button. 
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Sample 2 

 
Query: Select all the compounds whose tolerance are < 5 % in a specified formula. 

 
Steps: 

 
• Open a database file by selecting Open from File menu. As soon as a file is opened, the Reports 

Wizard appears. 
• Invoke the Advanced Reports window by clicking Advanced Reports button in the Wizard. 

Advanced Reports window will appear. 

• Click the New  toolbar button. A New Query window will appear. 
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• In Reports Type drop-down list, select Stored Formulation - Standard. 
• Enter a name in the name edit box and its description. 
• Click Ok button to save the query. Refer Fig 1. 
• In Field column of Advanced Reports screen select Formula_SNO, Formula_Name, 

Compound_Number, Raw_Material_Name, Raw_Material_ID, Target_Weight of compounds, 
Tolerance of compounds, Dispensed_Weight of compounds and Error_Percent of compounds all 
in seperate rows. Refer Fig 2. 

• In Formula_Name row select the '=' operator in operator column and in constraint1 column select 
the desired Formula Name. Refer Fig 2 and Fig3. 

• In Error_Percent of Compounds row, select '<' operator in operator column and enter value '5' in 
constraint1 column. 

• Click the Run toolbar button. 
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Sample 3 
 

Query: Select all formula dispensed where the target weight < 700 g and dispensed tolerance < 5 AND > 
0 and Dispensed_Date > 02/20/2002 and < 02/28/2002 which contain the certain compounds ‘Water’, 
‘Sugar’ or ‘Lemon’ and lot number is not empty 

 
Steps: 

 
• Open a database file by selecting Open from File menu. As soon as a file is opened, the Reports 

Wizard appears. 
• Invoke the Advanced Reports window by clicking Advanced Reports button in the Wizard. 

Advanced Reports window will appear. 

• Click the New  toolbar button. A New Query window will appear. 
• In Reports Type drop-down list, select Stored Formulation - Standard. 
• Enter a name in the name edit box and its description. 
• Click Ok button to save the query. Refer Fig 1. 
• In Field column of Advanced Reports window, select the Formula_SNO, Formula_Name 

,Formula_ID, Target_Weight, Dispensed_Weight, Error_Percent, Lot_Number, 
Compound_Number and Raw_Material_Name all in separate rows. 

• In Raw_Material_Name row, select the '=' operator in operator column and in constraint1 column 
select the Water, in condition column specify the OR operator, in operator column select '=' 
column and select the Sugar in Constraint2 column. 

• Add a new constraint (refer Constraints in Query Design topic).  
• In the new condition column specify the OR operator and select the Lemon in Constraint3 

column. 
• In Error_Percent of Formula row, select '<' operator in operator column and enter value '5' in 

constraint1 column and in condition column specify AND operator and in operator column 
specify the '>' operator which is next to condition operator and in constraint2 column enter the 
value 0. 

• In Dispensed_Date of Formula row, select '>' operator in operator column and enter value 
desired in constraint1 column and in condition column specify AND operator and in operator 
column specify the '<' operator which is next to condition operator and in constraint2 select the 
desired date. 

• In Lot_Number of Formula row, select '<>' operator in operator column and do not enter 
value in constraint1 column. Refer Fig 2 and Fig 3. 

• Click the Run  toolbar button. 
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Generated reports can be saved for future reference. It can be stored as a HTML file or an Excel file. 
 
Saving as HTML file 
 
Any type of report whether a graphical or text report can be saved as a HTML file.  
 

Reports can be saved by selecting Save as html option from the File menu or by pressing  toolbar 
button. 
 
For a Histogram, Plot Graph or a Pie Chart, a HTML file is created with a folder containing the report 
image. The image is created in JPEG format. The folder has its name “_files” added to the HTML file 
name and it is present in the same location as that of the file. 
 
For a Text Report, only a HTML file is created in the specified location. 
 
The HTML file can be customized by using templates. See Using Templates for more details. 
 
Saving as Excel file 
 
Text reports can be saved as an Excel file. Graphical reports can only be saved as HTML file. 
 
Reports can be saved as Excel files by selecting Save as xls option from the File menu or by selecting 

 toolbar button. 
 

 
 
Accelerator keys are shortcuts for reports. Frequently used reports can be assigned to an Accelerator 
(Shortcut Key). These shortcut keys to reports are specific for a user. Thus, each user can generate and 
save shortcuts for reports based on his/her specific needs. Accelerator keys are displayed in both MT-
FormTool and Reports main window. They can be shown/hidden by invoking the option Accelerator Keys 
option in View menu in MT-FormTool and Reports.  
 
To generator the accelerator key, follow the steps below, 
 
1. Start Reports from Tools menu. 
2. Design and produce a report using Wizard or Advanced Reports. 
3. Click any Accelerator key 1-6 in Reports window and select Associate with current report. Then the 

current report is stored and a message ‘Report is Stored’ is displayed. 
 
Note: 
Reports are stored based on the current user logged on to MT-FormTool. All user classes have a 
maximum of six different accelerator keys. 

 
Invoking Accelerator Keys: 
Accelerator keys can be invoked in both MT-FormTool and Reports windows. In MT-FormTool window 
clicking the Accelerator key containing the stored report will yield the same report in the reports window. In 
Reports, clicking the Accelerator key containing stored report and selecting the menu option Execute 
Store Report will produce the stored report. 
 

l. Saving Reports

m. Accelerator Keys 
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Accelerator Keys 

Accelerator Keys 
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The Reports application uses a report template to structure and style reports. Report templates are HTML 
files with Embedded Report Placeholders for the report data. When a standard template (Normal.html) 
is used for saving a report, all the data like header, graph and footer are retained in the HTML file. By 
default Normal.html file is used. 
 
Note: 
When MT-FormTool is installed, three html files will be copied (used as templates) in the templates 
directory under the installation directory. 
 
Custom Templates 
 
A custom template is used when the content or style of the standard report needs to be changed. Using a 
custom template user can create a report, which may contain only a subset of information generated from 
a standard template or with required additional information like description. 
 
Creating a Custom Template 
 
Use a copy of the standard template (Normal.html) or any of the sample templates (Sample1.html or 
Sample2.html) as a starting point to create custom templates. Here Embedded Report Placeholders may 
be removed to exclude the corresponding report data and additional data such as description may be 
added to the custom template. This copy can be altered to create a new design at user’s will. 
 
Setting Custom Templates 
 
After a custom template is created the settings of the Reports Wizard should be changed to make it use 
the custom template instead of the standard template. This is done by selecting Set Report Template 
option from the View menu. 
 
Sample Templates 
 
Two sample templates Sample1.html and Sample2.html files are provided to aid creation/understanding of 
custom templates. 
 
• Sample1.html adds a description to the report. 
• Sample2.html adds a logo at the top right corner of the report. This logo can also be customized by 

replacing the “logo.jpg” file with some other logo having the same name. This file is present in the 
Templates directory. 

•  

 
Header and Footer can be customized by choosing Header and Footer option from the View menu or by 

pressing  toolbar button. Also by right-clicking the header/footer area in the generated report and 
choosing the menu option will invoke the Header and Footer window. 
  
The location has to be selected in the Header and Footer interface and desired option has to be clicked. 
 
In Header and Footer window, select Insert Auto Text. A pop-up menu will be shown with the following 
options. 
 
Title: 
Each report has a title given by the application. This title is shown for this option. 

n. Using Templates 

o. Header / Footer Configuration
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File: 
Reports are generated for a database file. The name of the database file is displayed for this option. 
 
Page: 
This option allows the user to know the page number of the report .It would be useful in the Text report 
because only this report produces multiple pages. 
 
Date: 
This is the current date. The system date is taken for this option. 
 
Time: 
This is the current time. The system time is taken for this option. 
 
Custom: 
If any other text other than the above options is required, this option can be used. Here a separate 
interface is provided to get the custom text. Custom text can be up to a maximum of 250 letters. 
 
Clear: 
This option can be used to clear the contents in the specified (selected) location. 
 
The other options are, 
 
Font: 
This option allows the user to change the font of the text displayed for that particular location. 
 
Restore default: 
This option enables the user to restore the default header and footer settings if any. 
 
Set as default: 
This option sets the current header and footer configurations as the default setting. 
 
The Header and Footer window is shown below. 
 

 
 
 

 
In reports, the color of a bar (or a pie) and the background color of the graph area can be changed easily. 
 
Changing the color of a bar/pie/plot: 
To change the color, follow the steps below. 

p. Changing Fonts and Colors in Reports 
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1. Right-click on the appropriate bar or pie or plot-circle area. A pop-up menu will be displayed. 
2. From the menu, select the option Change Color.  
3. Select the desired color from the interface. 
  
After changing the color, the default color of bar, pie or plot-circle can be retained by selecting the option 
Default Color in the pop-up menu (Right clicking on the graph area will invoke a pop-up menu). 
 
Changing the background color of the graph: 
In Histogram and Plot graphs, the background area of the graph can be changed. 
 
To change the background color, follow the steps below. 
 
• Right-click on the graph’s background area. A pop-up menu will be displayed. 
• From the menu, select Change Color option.  
• Select the desired color from the interface. 
 
The background area of the graph is filled with the selected color. 
 
After changing the background color, the default color can be retained by selecting the option Default 
Color from the pop-up menu, which is created by right clicking on the graph area. 
 
Changing Fonts: 
In reports, fonts of the displayed texts can be changed. 
 
To change the font, follow the steps below. 
 
• Right-click on the appropriate text area. A pop-up menu will be displayed. 
• From the menu, select the Change Font option.  
• Select the desired font from the interface. 
 
The Default Font option from the pop-up menu is available for revert the changes. 
 

 
Tags act as a source of additional information for a graph. It can be easily added or removed from the 
graph. 
 
In graph, by right clicking the mouse on a bar or pie or a plot-circle, a menu will be displayed with an 
option Add Tag. If this option is selected, a tag is added to the corresponding graph. 
 
The tags can be removed from the graph. By right clicking the mouse on a tag-added bar or pie or plot-
circle, a menu with the option Remove Tag is displayed. Select this option to remove the tag from the 
corresponding graph.  
 

 
The generated report can be taken as a printout. It can be done by selecting Print option from the File 

menu or by pressing Print toolbar button. 
 
The standard Print dialog box lets you choose which printer should be used, how many copies are printed, 
whether to print in landscape or portrait mode, etc. 

q. Adding Tags

r. Printing Reports 
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The Print Preview option in the File menu shows the preview of the report. The toolbar button  can 
be used to preview the report. 
 

 
Depending on the range of values, the histogram report can have linear or non-linear scale along y-axis. 
 
In linear scale, each scale unit will be incremented with an absolute value. 
In non-linear scale, each scale unit will be incremented proportionally, where scale is logarithmic. 
 

 
When the Stored Formulation (Formula, RM and Message) database is modified, it may affect the reports 
based on Stored Formulation. When the existing database has to be modified, it is advisable to create a 
new file and then make necessary changes and update the changes to ID7. The Stored Formulation 
database alone can be exported/Imported to/from external database files. 
  
Reports may be affected and possibly incorrect when any of the following changes are made in Stored 
Formulation database: 
 
• Modifying Formula name 
• Modifying Raw material name 
• Deleting formula 
• Deleting raw material 
• Altering formula compounds (Deleting, adding and modifying formula compounds) 

 
Exporting Database: 
 
Exporting database will copy the Stored Formulation tables to the given database file from the currently 
opened file. Save As option copies the entire set of tables including Transaction records, where as Export 
will copy only Stored Formulation tables- RM Table, MSG Table and Formula Table. You can open the 
newly exported file as any other database file. 
 
The following procedure can be used to export database contents. 
 
1. Open the existing database file where the formula / raw material details have to be changed. 
2. Select Export from the File menu. 
3. Enter NEW file name and press Save button. The DB Configuration contents will be exported to this 

file. 
 
Importing Database: 
 
Import database option will copy the Stored Formulation tables from the given database file to the 
currently opened file. For importing database, the corresponding tables in the current file should be empty. 
That is, a new set of Stored Formulation Tables cannot be imported into a Database file that has these 
tables established. The import operation is allowed only once – when a New Database File is opened 
(after File->New operation). 

 
The following procedure can be used to create a new file with exported database contents. 
 
1. Create a New Database File. 
2. Select Import from the File menu and Import the saved DB Configurations. 

s. Linear / Non-Linear Scales

t. Impact on modifying database
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3. The Stored Formulation tables will be imported from the existing database file to the new file. 
4. Now change the database contents in the new file and download (or sync) this file to ID7 and start 

using this file. 
 
Note: 
When there are no dispensing details in the database file, you can change the database as you want 
because there are no dispensing details and therefore reports are not affected. 
 

 
 
If MT-FormTool is connected with ID7, the ID7 display panel shows the current scale weight, scale unit 
and scale id. If the scale weight is dynamic, then the ‘~’ symbol is shown instead of the scale unit. 
 
Changing Foreground and Background Colors: 

In the display panel, the foreground and background colors can be changed. 
 
To change the color, follow the steps below. 
 
1) Press the mouse right button on the display panel. A menu appears with BackColor and ForeColor 

options. 
2) Select any one option. The color dialog box will appear. 
3) Choose the desired color and press OK button. 
 
The display shows the corresponding background color and foreground color. When the application is not 
connected with iD7, you may not be able to see the foreground color since there is nothing to display. 
 
Hide/Show Panel 
 
The ID7 display can be made hide/visible by selecting Panel option from the View menu. 
 

 
MT-FormTool application supports multi-lingual feature. 
 
It provides six languages that are listed below: 
 
1) German 
2) English 
3) French 
4) Dutch 
5) Italian 
6) Spanish 
 
To change the language, select any one of the available six languages from the Language menu. The 
application will show all the texts (including menu items) in the selected language. The current language is 
shown with a tick symbol in the Language menu. When the application starts the next time, all the texts 
will be shows in the selected language. 
 
 
 

7. ID7 Display Panel 

8. Multi-Lingual support 
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Multiple instances of MT-FormTool can manage multiple ID7 terminals. All the data collected by these 
instances can be logged on to a single or multiple database files. The following diagram (Figure-1) shows 
the multiple instances running and all the data collected are logged on to a single database file. 
 
 
 

 
 
 
The above diagram (Figure-1) has three instances of MT-FormTool connected with three FormPac ID7 
terminals and all the data collected by these three instances are logged on to a single database file. Here 
single database file manages all the data of three ID7 terminals. 
 
 
 

 
 
 
The above diagram (Figure-2) has four instances of MT-FormTool connected to four FormPac ID7 
terminals. Data collected by the instances A & B is logged on to the File_ab.mdb and data collected by 
instances X & Y are logged on to the File_xy.mdb. Here two different database files manage the four ID7 
terminals.  
 
 

9. Managing Sessions 
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MT-FormTool maintains the stock values for the raw materials if the Track Inventory option is enabled. 
This feature is useful when multiple FormPac-XP units are tracked  on the same system using a single 
database file. Whenever a compound is dispensed, its stock value is updated within the ID7 and also  in 
the database (.mdb file) maintained in the PC. In case of multiple ID7s using the same store, the stock 
value maintained by the FormPac-XP on ID7 may not be correct as they do not account for the usage of 
raw-materials by other FormPacXP units. Therefore it is necessary to correct the stocks on ID7 
periodically with the correct value tracked by FormTool.  
To update the stock values on FormPac-XP from the values tracked by FormTool, click the Stock toolbar 
button in DB Configuration window. Select Update Stock from the pop-up menu. A confirmation message 
will be displayed. And if the TIDs (Table Ids) of the current database are not the same as TIDs in ID7, then 
a warning message will be issued. 
 
If Enable Store option is enabled (via Inventory Control option from the View menu), then stock values 
will be taken from the corresponding store. Otherwise stocks will be taken from the raw materials 
database. 
 
Note: 
The stock value is updated locally in the database file only if Track Inventory option is enabled. To 
enable Track Inventory, select Inventory Control from the View menu. From the Inventory Control dialog 
box, check the Track Inventory option. 
 

 
Inventory control tracks stocks in all the ID7 terminals associated with the current database file. Stocks of 
ID7 terminals can be managed individually,  or in groups, or ignored. Inventory is managed by the 
Inventory Control window, which can be selected from the View menu.  
 
Inventory Control Window: 
Inventory control has Track Inventory option. Multi Stores or Groups can be managed by activating 
‘Enable Stores’ option under this control. 
 
Inventory tracking: 
Track Inventory and Enable Stores options: 
 
1) If ‘Track inventory’ option is disabled, then stocks of Raw Materials are not updated on dispensing. 

They are ignored. 
 
2) If ‘Track inventory’ option is enabled and ‘Enable Stores’ option is not enabled, then all the ID7 

terminals belonging to the current database file are considered as a single group and the stocks 
values of the Raw Materials are updated during dispensing as the raw-materials are consumed. If the 
original stock levels are incorrect, it is possible that the inventory values become zero or even 
negative when the raw materials are consumed during formulation 

 
3) If ‘Track inventory’ option is enabled and ‘Enable Stores’ option is also enabled, then Stocks of 

Raw Materials can be managed in Stores (groups otherwise). Stores are nothing but a group of ID7 
terminals. There can be up to 10 Stores within a database file and each store can have up to 10 ID7 
terminals. So stocks of 100 ID7 terminals can be managed from a single database file. 

  
 
 
 

10. Updating Stock

11. Inventory Control 
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Store Details 
 
Details of the stores can be viewed in table below the Store Details text in inventory control window. The 
table shows the list of ID7 terminals and their assigned stores. Each ID7 terminal can be assigned to any 
available store by simply clicking the required store cell in Store Column and selecting the desired Store 
from the list of stores. New stores can be added by clicking Add Store button and by entering the name of 
the store (Store name cannot contain spaces, instead of spaces underscore or other characters can be 
used). The newly added store is available in Stores list of the Stores column. 
 
Connection Details 
 
When Track Inventory and Enable Stores options are enabled, then on connecting  with ID7 terminal, 
Terminal Id of ID7 is read and checked the list maintained for each store in the  database file. If the ID7 
terminal does not belong to any of the stores or if there are no stores in database file, then Assign Store 
window is prompted.  
  
Assign Store window can be used to assign the currently connected ID7 terminal to any one of the 
available stores or to a new store.  
 
• The list of available stores is shown in the Assign Store list 
• New store can be created by clicking the New Store button and by entering the name of the new store 

(Store name cannot contain spaces).  
• Select the store name from the list. 
• If you don’t want to assign a store for the connected terminal, just select the empty store name 

available in the list. 
• Press OK button. 

 
Now the selected store will be assigned to the connected ID7 terminal. If Cancel button is pressed, no 
store will be assigned. Later, stores can be altered by choosing Inventory Control from the View menu.   
 

 
 
Editing Current Store 
 
DB Configuration window shows the store as stock. If the MT-FormTool is connected to an ID7 terminal 
and if Enable Stores option is enabled, then Raw Materials table in DB Configuration window shows the 
Store (Stock) values (in the stock column) that the current ID7 terminal belongs to. 
 
Updating Stock (for current store) 
 
Updating stock to ID7 is writing stock details of Raw Materials from the MT-FormTool to ID7 terminal. 
Stock values for the current store can be updated by clicking the Stock toolbar button in DB Configuration 
window and selecting the Update Stock option from the pop-up menu. The stock values are updated 
accordingly. 
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Editing All Stores 
 
All the stores in database file viewed together. To view all the stores click ‘Stock’ button and select the 
‘View all stores’ option form the menu in DB Configuration window. All the stores are shown and each of 
the stores can be edited individually but Raw material id and its name are not allowed to change. Raw 
materials can be viewed again by clicking ‘Stock’ button and deselecting the ‘View all stores’ menu 
option. 
 
Other cases: 
  
No Connection and Track Inventory and Enable Stores are enabled 
 
If there is no connection with ID7 terminal, ‘Track Inventory’ and ‘Enable Stores’ options are enabled, then 
store shown in Raw Materials table of DB Configuration window will be empty, since the MT-FormTool 
does not know which available store to show. So stock value cannot be updated in Raw Materials table. 
However the stock value can be updated using the option ‘View all Stores’ in Stock button. So on a 
disconnected status and the above options are enabled, use the ‘View all Stores’ option to change 
the stock value. 
 
Note: 
Inventory control doesn’t keep track of consumed quantity in Raw Materials table. It reflects the quantity 
last read from ID7. 
 

  
User management determines the level of access to the MT-FormTool. User management prevents users 
from making careless mistakes. There are 3 different types of users namely Administrator, Supervisor and 
Operator. The access rights for the users are shown in the following table. 
 

  
View DB/ 
Logging 

DB Creation/ 
Open/Save 

Edit DB Download/ 
Upload 

View 
Reports 

Inventory 
Control 

User 
Management

Operator Yes No No Yes Yes No No 
Supervisor Yes Yes Yes Yes Yes Yes No 
Admin Yes Yes Yes Yes Yes Yes Yes 
 

 
The administrator manages users.  

 
To add new user, follow the steps below 

 
1. Select User Settings in the User menu. The User Settings dialog appears. 
2. Click the Add button. 
3. Enter the user name and access privilege. (Only Supervisor and Operator privilege can be set) 
4. The administrator can view the user rights by clicking the View Rights button.  
5. Click the OK button 
 
To set password to a user follow the steps below 
 
1. Select User Settings in the User menu. The User Settings dialog appears. 
2. Select the user in user name table and click the Set Password button.  
3. Enter new password and confirm the new password in the pop up window. (Old password is not 

needed) 
4. Click the Done button to update the changes 

 

12. User Management 
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Only the administrator can change the password for other users. All the other users are allowed to change 
their own password alone. If the administrator changes his/her own password then old password is 
prompted. The user name is 30 characters and password size is 10 characters.  
 
The administrator can add/modify/delete the users. Deleting the user deletes the user with all the 
accelerator key reports for that user. The administrator can modify the access privilege for the other users. 
The administrator name cannot be changed. There can be 1 administrator, 2 supervisors and 5 operators 
for a PC. 
 
When Login dialog displayed: 
When the MT-FormTool is installed, there will be only one user (that is admin) and no password is set for 
admin. In this case, login dialog won’t be displayed. In this case, the user name will be taken as admin. 
When the admin changes the password or if more users are added, then login dialog will be displayed 
every time the application starts. 
 
How to logon: 
The current login name will be displayed in the window title along with the application name (If no user 
name is displayed, then it means no user has logged in). 
 
1. Select Logon option from Users menu. Login dialog will be displayed. 
2. Enter the user name and password. If successfully logged in, then current login name will be shown in 

the window title. 
 
How to logoff: 
Select Logoff from Users menu. If the user is logged off, the MT-FormTool will be disconnected from ID7 
and it will try to close the reports window if any opened. 
 
Note: 
User logging information is stored in the file ‘logfile.txt’ in the MT-FormTool installation directory. The 
option Clear logged Info in the Tools menu will delete this file and the connection status (Session 
Information) in the database file. 
 

 
The following are the possible error messages shown by MT-FormTool and the description of the error 
message. 
 
Communication Error Messages 
 
Connection failed 
 
The specified PC port may be connected with other application. Verify the PC port with which ID7 is 
connected and change the PC port number by selecting Interface Settings from the Options menu or 
pressing Settings   toolbar button. Then connect again by selecting Connect from the File menu. 

 
Cannot establish connection with the system 
 
The specified IP address is not correct or the Ethernet port number is not correct. Verify the Ethernet IP 
address and Ethernet port number in ID7 and change the Ethernet settings by selecting Interface 
Settings from the Options menu or press Settings   toolbar button. 

 
 

13. Error messages
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No response from ID7 
 
If the COM-Port (PC Port) settings are wrong or if the ID7 terminal is not connected with PC, this error 
message is shown. 

  
Make sure that the ID7 terminal is connected with the PC and it is switched on. Verify the interface 
settings both in ID7 and in MT-FormTool. Change the interface settings (baud rate, data bits, parity, stop 
bits and Frame String [CR, LF, STX_ETX and CheckSum] options) so that interface settings are same 
both in ID7 and in MT-FormTool. Now select Disconnect  from the File menu and select Connect  
to connect again.  
 
BasePac/FormPac version error 
 
If the Pac (bin) version in ID7 is not compatible with the MT-FormTool, this error message is shown. MT-
FormTool is designed for FormPac-XP Version 2.08. Download the correct Pac (bin) and connect with 
MT-FormTool again.  
 
At sometimes due to some communication problems, this error message is shown. In those cases just 
disconnect and connect with ID7 again. If the same error message is repeated, then try changing the PAC 
in ID7. 
 
The unit is already monitored by the MT-FormTool 
 
If an ID7 terminal is connected by the MT-FormTool and if another instance of MT-FormTool is trying to 
connect with the same ID7 terminal, this message will be shown. Multiple instances of MT-FormTool 
cannot monitor the same ID7 terminal. 
 
File Error Messages 
 
Unable to open the file. The file may be corrupted or invalid. 
 
If the file is not created by the tool or if the database file format is different, then this error message is 
shown. Open a valid database (.mdb) file or create a new database file by selecting New from File menu. 
 
Error occurred while saving 
 
If the given file in the Save As dialog box already exists and is used by some other application, this error 
message is shown. Either close the other application that uses the file or give a different name and save 
again. 
 
Error occurred while creating new file 
 
If the file name entered in the ‘New’ dialog box already exists and if it is used by some other application, 
then the tool cannot create a file with the same name. Enter some other name or close the other 
application that uses the file. 
 

 
The tables used in MT-FormTool are categorized into five groups as shown below. The database schema 
structure for each of the following table is explained with all field details. Select the category to view its 
table structure. 
 
 
 

14. Database Structure 
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• DB Configuration Tables 
• Stored Formulation Dispensing Tables 
• Formulation Tables 
• Pharma Formulation Tables 
• Totalizing Tables 
 
 
The relationships between the tables are shown below. 
 
1) Relationship between Stored Formulation Dispensing tables 
2) Relationship between Stored Formulation Batch-Dispensing tables 
3) Relationship between Formulation Application tables 
4) Relationship between Formula and Formula-Trailer tables (used in DB Configuration) 
 

 
In this section, tables related to DB Configuration database are listed. There are four tables in this section. 
They are listed below. 
 
1) Formula 
2) Formula_Compounds 
3) Raw_Materials 
4) Messages 
 
Schema structure for Formula table: 
Table name: Formula 
 
 
No Field Name  Type Size Comments 
1 Index Long 4 Auto increment number 
2 Formula_ID Text  11 Formula ID (Unique) 
3 Formula_Name Text 31 Formula Name 
4 Target_Weight Text 15 Formula Target (designed) Weight 
5 Tolerance Integer 4 Formula Tolerance: Addition of compound 

tolerances. 
6 Total_Compounds Integer 4 Total no of compounds for a formula. 
7 Pre_msg_1 Integer 4 Pre Message-1 
8 Pre_msg_2 Integer 4 Pre Message-2 
9 Pre_msg_3 Integer 4 Pre Message-3 
10 Post_msg_1 Integer 4 Post Message-1 
11 Post_msg_2 Integer 4 Post Message-2 
12 Total_Dispensed_Weight Text 16 Total dispensed weight 
13 Total_Cleared_Date Date/Time 8 Total Cleared Date: Date at which formula total is 

cleared. 
14 Total_Cleared_Time Date/Time 8 Total Cleared Time: Time ate at which formula total 

is cleared. 
15 Status Integer 4 Formula status in ID7 can be either Edit mode or 

Complete mode or Invalid. (not used generally) 
16 Valid Integer 4 For internal use. 
17 Edit_Status Integer 4 For internal use. 

 
 
 
 

a. DB configuration Tables 



FormToolXP – Operating Instructions 
 
 

Page 53 of 60 
FormToolXP_Operating Instructions_engl.doc                                                                                                                          

Schema structure for Formula table: 
Table name: Formula_Compounds 
 
No Field Name  Type Size Comments 
1 Formula_ID Text 30 For internal use 
2 Raw_Material_ID Text  21 Raw Material ID 
3 Raw_Material_Name Text 31 Raw Material (Compound) Name 
4 Target_Weight Text 15 Compound target weight 
5 Tolerance Integer 4 Compound Tolerance weight 
6 Pre_msg Integer 4 Pre Message 
7 Post_msg Integer 4 Post Message 
8 Id Integer 4 Foreign key from Formula table  
9 Edit_Status Integer 4 For internal use 

 
 
Schema structure for Raw Materials table: 
Table name: Raw_Materials 
 
No Field Name  Type Size Comments 
1 Index Integer 4 Auto increment number 
2 Raw_Material_ID Text  21 Raw Material Id 
3 Description Text 31 Raw Material Name 
4 Stock Text 15 Raw Material stock 
5 Warning Integer 4 Warning 
6 Msg_NO Integer 4 Message No 
7 Used_Count Integer 4 Raw Material Used Count 
8 Consumed Text 15 Raw material consumed 
9 Stock_Date Date/Time 8 Stock updated date 
10 Stock_Time Date/Time 8 Stock updated time 
11 Edit_Status Integer 4 For internal use 

 
 
Schema structure for Messages table: 
Table name: Messages 
 
No Field Name  Type Size Comments 
1 Index Integer 4 Auto increment number 
2 Description Text  30 Message text 
3 Edit_Status Integer 4 For internal use 

 
 

 
In this section, tables related to dispensing section of stored formulation are listed. There are five tables in 
this section. They are listed below. 
 
1) Formula_Dispense 
2) Compound_Dispense 
3) CompoundDispense_Multi_Charge 
4) CompoundDispense_Batch 
5) CompoundDispense_BatchDetails 
 
 
 

b. Stored Formulation Dispensing Tables
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Stored Formulation Dispensed Formula Details Header 
Table Name: Formula_Dispense 

 
No Field Name Type Size Comments 
1 Formula_SNO Long 4 Auto increment number 
2 ID7_UnitID Text 21 Terminal ID from ID7 
3 UserName Text 20 User name 
4 Dispensed_Date Date/Time 8 PC- Date: Dispensed start date 
5 Dispensed_StartTime Date/Time 8 Dispensed Start Time: Start of formulation 
6 Dispensed_EndTime Date/Time 8 Dispensed End Time: End time when formulation 

is done 
7 Formula_No Integer 2 Formula number 
8 Formula_ID Text 11 Formula ID varies from [1-150] 
9 Formula_Name Text 31 Formula name  
10 Lot_Number Text 21 Lot Number: Optional - user entry at ID7 
11 Total_Compounds Integer 2 Number of compounds in a formula varies from [1-

100] 
12 Target_Weight Text 15 Ideal target of formula 
13 Tolerance Float 4 Tolerance weight +/- limits 
14 Dispensed_Weight Text 15 Total dispensed weight of compounds 
15 Error_Percent Float 4 Dispensed Tolerance weight percentage. 

Deviation from Target (+/-) 
16 Tare_Weight Text 15 Tare Weight 
17 Total_Batches Integer 2 Number of batches for a formula 
18 Formula_Status 

 
Integer 2 Formula Dispensed status (Dispensed, parked, 

cancelled or interrupted) 
19 Flag_Byte Text 101 For internal use 
20 Split_Count Text 101 For internal use 
21 Code_C_Key Text 31 C key read from ID7 
22 Code_D_Key Text 31 D key read from ID7 

 
 
Stored Formulation Components Details Trailer 
Table Name: Compound_Dispense 
 
No Field Name  Type Size Comments 
1 Compounds_SNO Long 4 Auto increment number 
2 Compound_Number Integer  2 Compound number varies from (1-100) 
3 Formula_SNO Long 4 Foreign key from formula table 
4 Raw_Material_ID Text 21 Raw Material ID (Unique) 
5 Raw_Material_Name Text  31 Raw Material Name 
6 Charge_Number Text  21 Charge Number: Optional-user entry at ID7 
7 Target_Weight Text  15 Ideal weight of the compound  
8 Tolerance Float 4 compound Tolerance Wt +/- Limits 
9 Dispensed_Weight Text 15 Dispensed weight of the compound 
10 Error_Percent Float 4 Dispensed tolerance: Deviation from Ideal 

Target weight 
11 Dispensed_Tolerance2 Float 4 Dispensed Tolerance2 
12 Dispensed_Status Byte 1 Compound dispensed status: Shows whether 

compound was dispensed manually or through 
scale  

13 Start_Time Date/Time 8 PC-Time: Dispensing start time of the compound 
14 Scale_Id Integer 2 Scale Id: Shows in which scale the compound 

was dispensed 
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Compound Dispense Split table 
Table Name: CompoundDispense_Mutli_Charge 
 
No Field Name  Type Size Comments 

1 Mutli_Charge_SNO Long 4 Auto Increment Number 
2 Compound_Number Integer 2 Compound Number  
3 Compounds_SNO Long  4 Foreign key from CompoundDispense table  
4 Dispensed_Weight Text 15 Split dispense weight 
5 Charge_Number Text 21 Split charge number 
6 Dispensed_Status Text 1 Shows whether compound dispensed manually or through 

scale 
7 Start_Time Date/Time 8 Start time of dispensing 
8 Scale_ID Integer 2 Scale Id: Shows in which scale the compound was dispensed

 
 
Stored Formulation Batch Details Trailer 
Table Name: CompoundDispense_Batch 

 
No Field Name  Type Size Comments 
1 Batch_SNO Long 4 Auto Increment Number 
2 Compound_Number Integer 2 Compound Number [1-100] 
3 Formula_SNO Long 4 Foreign key from formula table 
4 Raw_Material_ID Text 21 Raw Material ID 
5 Raw_Material_Name Text 31 Raw Material Name 
6 Charge_Number Text 21 Charge Number: Optional user entry at ID7 
7 Target_Weight Text 15 Ideal weight of the compound (Target Wt) 
8 Tolerance Float 4 Compound Tolerance Wt +/- Limits 

 
 
Stored Formulation Batch Weight Details: 
Table Name: CompoundDispense_BatchDetails 
 
No Field Name  Type Size Comments 
1 BatchDetails_SNO Long 4 Auto Increment Number 
2 Batch_SNO Long 4 Foreign key for formula table 
3 Dispensed_Weight Text 15 Compound dispensed weight 
4 Error_Percent Float 4 Dispensed Tolerance: Deviation from Ideal 

Target weight 
5 Dispensed_Tolerance2 Float 4 Dispensed Tolerance2 
6 Tare_Weight Text 15 Container weight 
7 Batch_ID Text 21 Batch Id of current batch 
8 Start_Time Date/Time 8 Dispensing start time of compound 
9 Scale_Id Byte 1 Scale Id: Shows in which scale the compound 

was dispensed 
10 Batch_No Integer 2 Iteration number [1-100] 
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In Formulation application, two tables are used. They are listed below.  
 
1) Formulation_Container 
2) Formulation_Compounds 

 
 
Schema structure for Formulation Container table: 
Table name: Formulation_Container 
 
No Field Name  Type Size Comments 
1 Container_SNO Integer 4 Auto increment number 
2 Recipe_Name Text 31 Recipe Name 
3 Container_Weight Text 15 Container weight 
4 Tare_Weight Text 15 Tare weight 
5 Dispensed_Date Date/Time 8 Dispensed Start Date 
6 Dispensed_StartTime Date/Time 8 Dispensed Start Time: Time when container is 

loaded 
7 Dispensed_EndTime Date/Time 8 Dispensed End Time: End time when container is 

closed 
8 Code_B_Key Text 31 B key read from ID7 
9 Code_D_key Text 31 D key read from ID7 

 
 
Schema structure for Formulation Compounds table: 
Table name: Formulation_Compounds 
 
No Field Name  Type Size Comments 
1 Container_SNO Integer 4  
2 Compound_No Integer 4 Component number varies from [1-15] 
3 Compound_Name Text 21 Component name 
4 Compound_Weight Text 15 Component weight 
5 Dispensed_StartTime Date/Time 8 Dispensed Start Time for compound 
6 Dispensed_Status Integer 4 Component dispensed status: Shows 

whether component was dispensed 
manually or through scale 

7 Scale_ID Integer 4 Scale Id: Shows in which scale the 
compound was dispensed 

 
 

 
In Pharma Formulation only one table is used. The schema structure for Pharma Table is listed below. 
 
 
 
 
 
 
 
 
 

c. Formulation Tables 

d. Pharma Formulation Tables
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Schema structure for Pharma Table: 
Table name: Pharma_Formulation 
 
No Field Name  Type Size Comments 
1 Pharma_SNO Integer 4 Auto increment number 
2 Component_Name Text 31 Component name 
3 Component_Weight Text 15 Component weight 
4 Tare_Weight Text 15 Tare weight 
5 Start_Date Date/Time 8 Dispensed Start Date for compound 
6 Start_Time Date/Time 8 Dispensed Start Time for compound 
7 Dispensed_Status Date/Time 8 Component dispensed status: Shows whether 

component was dispensed manually or through 
scale 

8 Scale_ID Integer 4 Scale Id: Shows in which scale the compound was 
dispensed 

9 Code_A_Key Text 31 A key read from ID7 
10 Code_B_Key Text 31 B key read from ID7 
11 Code_D_Key Text 31 D key read from ID7 

 

 
In Totalizing application only one table is used. The schema structure for Totalizing table is listed below. 
 
Schema structure for Totalizing Table: 
Table name: Totalizing 
 
No Field Name  Type Size Comments 
1 Totalizing_SNO Integer 4 Auto increment number 
2 Component_Name Text 31 Component Name 
3 Component_Weight Text 15 Component weight 
4 Dispensed_Date Date/Time 8 Component dispensed date 
5 Dispensed_Time Date/Time 8 Component dispensed time 
6 Dispensed_Status Date/Time 8 Component dispensed status: Shows whether 

component was dispensed manually or through 
scale 

7 Scale_ID Integer 4 Scale Id: Shows in which scale the compound was 
dispensed 

8 Code_A_Key Text 31 A key read from ID7 
9 Code_B_Key Text 31 B key read from ID7 
10 Code_D_Key Text 31 D key read from ID7 

 
 

 
There are two ways to uninstall MT-FormTool. 
 
1. From the Start menu click Programs, then Mettler Toledo, and then Uninstall MT-FormTool. 
2. Activate the Control Panel (Start Menu -> Setting -> Control Panel), double click Add/Remove 

Programs, and double click on the MT-FormTool list box entry. 
 
 

e. Totalizing Tables 

15. Uninstalling the software
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Terms used in MT-FormTool 
 
Actual/Dispensed Tolerance Weight, Delta, Error 
Difference between the Actual and Target weight of a compound 
 
Actual Weight 
Dispensed compound weight 
 
Batch Filling 
One of the dispensing modes in Stored Formulation application that is used to dispense each compound 
in a formula "n" times iteratively, thus resulting in "n" batches. 
 
Cancelled 
Message text in MT-FormTool indicating that the dispensing has been cancelled in the middle of 
dispensing. 
 
Charge Number 
Additional information-text pertaining to each compound in a formula, provided for user-entry when each 
compound is selected for dispensing. 
 
Connected Terminal Id 
Active ID7 terminal for which the monitoring is in progress 
 
Consumed 
Used weight of the active Raw Material 
 
End Time 
Time when a formula is dispensed completely. 
 
Expand  
Option to view compounds in enlarged window 
 
Formula 
This is the actual stored formula. A formula can contain up to 100 compounds, each using a Raw Material 
and having individual target and tolerance values. The formula database can store up to 150 entries. 
 
Formula ID 
Abbreviation for Formula Identifier (Alphanumeric text of maximum 10 characters) 
 
Formula Name 
Name of the stored formula (Alphanumeric text of maximum 30 characters) 
 
Histogram 
Graphical bars showing dispensed parts. 
 
Horizontal Filling 
One of the dispensing modes in Stored Formulation application that is used to dispense the compound in 
the formula in individual containers. 
 
Interrupted 
Message text in MT-FormTool indicating that the monitoring has been interrupted in MT-FormTool. 
 
 

16. Glossary
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Linear scaling 
In linear scaling, each scale unit will be incremented with an absolute value. 
 
Lot Number 
Additional information-text pertaining to a formula, provided for user-entry when a formula is selected. 
 
Message 
These are texts/actions for user notification during dispensing a formula in Stored Formulation. 
 
MSG Id (Message Id) 
Abbreviation for Message-Number in the message database. Valid range is 1 to 200.  '0' indicates that no 
message is used. 
 
Non-linear scaling 
In non-linear scaling, each scale unit will be incremented proportionally, where each proportion is 
logarithmic. 
 
Panel 
MT-FormTool Window at the top, in which ID7 screen is simulated 
 
Pie Chart 
Graphical sectors showing dispensed parts. 
 
Post (Msg) 
Indicates Post-Formula or Post-Compound Message 
 
Pre (Msg) 
Indicates Pre-Formula or Pre-Compound Message 
 
Progress Bar 
Graphical bars showing dispensed parts. 
 
Raw Materials (RM) 
These are items that the stored formula uses. Raw Materials are stored in a database that can store up to 
500 Raw Materials. 
 
Read 
Command to Read Stored Formula databases from ID7 
 
Report Wizard 
Tool that generates reports for monitored details. 
 
RM Description (RM Name) 
Abbreviation for Raw Material Name (Alphanumeric text of max. 30 characters) 
 
RM Id 
Abbreviation for Raw Material Id. (Alphanumeric text of max. 20 characters) 
 
Send 
Command to Write Stored Formula databases to ID7 
 
Shrink 
Option to view compounds in minimized window 
 
Split Dispensed Weight 
Partial dispensed weight of a compound 
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Start Time 
Time when a formula or compound has been invoked for dispensing 
 
Stock 
Remaining Stock of the active Raw Material 
 
Stock Date/Time 
Date and Time when stock was updated for the active Raw Material 
 
Stored Formulation 
One of the applications in FormPac-XP that supports formulation and dispensing. This application 
supports three dispensing modes namely VERTICAL, HORIZONTAL and    BATCH fillings. Features like 
scaling a stored formula, rescaling on error generation    and saving & restoring of a formula are available. 
 
Synchronization (Sync) 
Method to update changes done in MT-FormTool in ID7 
 
Tags 
Tags act as a source of additional information for a graph. 
 
Target Weight 
Target weight of the compound for the stored formula. 
 
Templates 
Template determines the content or style of the report. 
 
Terminal Id 
ID7 terminal to which the active formula belongs. 
 
Tolerance Weight 
Tolerance of the compound for the stored formula. 
 
Used Count 
Usage count of the raw material by the formulae 
 
Vertical Filling 
One of the dispensing modes in Stored Formulation application that is used to dispense all the 
compounds in the formula in a single container (vertically). 
 
Warning 
Stock warning pertaining to active Raw Material 
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